Your SlideShare is downloading. ×
  • Like
Algoritmos e programação - Aula 7
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×

Now you can save presentations on your phone or tablet

Available for both IPhone and Android

Text the download link to your phone

Standard text messaging rates apply

Algoritmos e programação - Aula 7

  • 5,363 views
Published

Slides referentes a 7ª aula da disciplina de Algoritmos e Programação, realizada no dia 25/02/2011

Slides referentes a 7ª aula da disciplina de Algoritmos e Programação, realizada no dia 25/02/2011

Published in Technology
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Be the first to comment
No Downloads

Views

Total Views
5,363
On SlideShare
0
From Embeds
0
Number of Embeds
1

Actions

Shares
Downloads
189
Comments
0
Likes
3

Embeds 0

No embeds

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
    No notes for slide

Transcript

  • 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 7
  • 2. Sumário
    • Estruturas de Repetição ;
      • Repita...ate ;
  • 3. Estruturas de Repetição
    • Até o momento, quando existe a necessidade de repetir uma (ou mais) instruções, a única saída é repetir o(s) comando(s);
    • Tal solução é ineficiente considerando que quanto maior o número de repetições maior será o número de instruções;
      • Ex.: Escrever um algoritmo que exiba na tela a frase “Sport campeão de 87” 300 vezes;
    • Solução: Utilizar estruturas de repetição;
  • 4. Estruturas de Repetição
    • Saõ estruturas sintáticas que permitem que um trecho de algoritmo (lista de comandos) seja repetido em um determinado número de vezes;
    • Em Portugol, temos três estruturas de repetição: repita...ate , enquanto...faca e para...faca ;
  • 5. Repita...ate
    • Nesta estrutura, todas as instruções são executadas e uma expressão lógica é avaliada;
    • Isto se repete até que a avaliação da condição resulte em FALSO ;
    • Cada repetição da lista de instruções contidas na estrutura é chamada de iteração ;
    • A estrutura Repita...ate também é conhecida como laço de repetição ;
  • 6. Repita...ate
    • Utilizamos as palavras reservadas repita e ate para formar o laço de repetição;
    • Forma geral:
    • repita
    • // Lista de instruções
    • ate expressão lógica
  • 7. Repita...ate
    • Exemplo - Algoritmo que escreve os números de 1 a 10:
    • algoritmo “Mostra10”
    • var numero: inteiro
    • inicio
    • numero <- 1
    • repita
    • escreva(numero)
    • numero <- numero + 1 // contador
    • ate numero > 10
    • fimalgoritmo
  • 8. Repita...ate
    • Exemplo 2 - Algoritmo que escreve os números PARES entre 1 e 10:
    • algoritmo “Mostra10”
    • var numero: inteiro
    • inicio
    • numero <- 1
    • repita
    • se (numero % 2 = 0) entao
    • escreva(numero)
    • fimse
    • numero <- numero + 1 // contador
    • ate numero > 10
    • fimalgoritmo
  • 9. Repita...ate
    • Atenção: Cuidado com laços infinitos ! Devemos nos certificar que em algum momento a expressão lógica próxima a palavra reservada ate será FALSA!
  • 10. Repita...ate
    • Exemplo 3 – Algoritmo com um laço infinito:
    • algoritmo “lacoInfinito”
    • var contador: inteiro
    • inicio
    • repita
    • contador <- 1
    • escreva(contador)
    • contador <- contador + 1
    • ate contador = 10
    • fimalgoritmo
  • 11. Repita...ate
    • Exemplo 4 – Algoritmo com um menu:
    • algoritmo “menu”
    • var opcao: inteiro
    • inicio
    • repita
    • escreval(“Cadastro de Clientes”)
    • escreval(“1 - Incluir”)
    • escreval(“2 - Alterar”)
    • escreval(“3 - Consultar”)
    • escreval(“4 - Excluir”)
    • escreval(“5 - Sair”)
    • leia(opcao)
    • ate opcao = 5
    • fimalgoritmo
  • 12. Exercícios
    • Escreva um algoritmo que some os números entre 1 e 10, escrevendo o resultado final;
    • Faça um algoritmo que repita 10 vezes a seguinte frase: A CBF é uma vergonha!
    • Faça um algoritmo que lê número inteiros até que um número negativo seja digitado;
    • Faça um algoritmo que lê a idade de 15 pessoas e mostre a quantidade de pessoas que possui a idade entre 0 e 12 anos;