• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Algoritmos e programação - Aula 6
 

Algoritmos e programação - Aula 6

on

  • 4,184 views

Algoritmos e programação - Aula 6

Algoritmos e programação - Aula 6

Statistics

Views

Total Views
4,184
Views on SlideShare
4,164
Embed Views
20

Actions

Likes
3
Downloads
62
Comments
0

1 Embed 20

http://ead.unipe.br 20

Accessibility

Categories

Upload Details

Uploaded via as Adobe PDF

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Algoritmos e programação - Aula 6 Algoritmos e programação - Aula 6 Presentation Transcript

    • Profº Thyago M iP fº Th MaiaAlgoritmos e Programação Aula 6
    • Sumário S áiEstruturas Condicionais
    • Comando de Seleção Múltipla• Em algumas situações é necessário analisar mais que duas condições;• O comando se nos permite implementar tais situações, situações porém de forma limitada e em e, alguns casos, ineficiente: • Imagine implementar 100 estruturas se para 100 condições diferentes! • Tal comando obriga o programador a escrever g ; várias linhas de código;
    • Comando de Seleção Múltipla• Para várias condições, podemos utilizar o comando de seleção múltipla escolha;• Sintaxe: escolha (variavel) Caso valor_1 // Instruções que serão executadas caso // a condição seja verdadeira Caso valor 2 valor_2 // Instruções que serão executadas caso // a condição seja falsa Outrocaso // Instruções que serão executadas se // nenhuma condição anterior seja atendida fimescolha
    • Comando de Seleção Múltipla• As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional;• Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso; p ;• O caso tem funcionamento similar ao se;• O outrocaso tem funcionamento similar ao senao, visto anteriormente; , ;
    • ExemploAlgoritmo “exemplo caso” exemplo_casoVar sexo: literalInicio escreval( Digite escreval(“Digite seu sexo (M ou F): ”) ) leia(sexo) escolha(sexo) caso “M” escreval( O escreval(“O usuário é homem”) homem ) caso “F” escreval(“O usuário é mulher”) outrocaso escreval(“Erro de caractere!”) fimescolhafimalgoritmo
    • Exemplo 2Algoritmo “exemplo caso 2” exemplo_caso_2Var time: literalInicio escreval( Digite escreval(“Digite seu time: ”) ) leia(time) escolha(time) caso “sport” escreval( Parabéns!!! ) escreval(“Parabéns!!!”) outrocaso escreval(“Meus pêsames!”) fimescolhafimalgoritmo
    • Exercícios• Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente sendo correspondente, domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma faixa mensagem de erro;
    • Exercícios• Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário O usuário. resultado deverá ser exibido em seguida;
    • Sumário• Estruturas de Repetição • ENQUANTO...FACA
    • Estruturas de Repetição• Até o momento, quando existia a necessidade de repetir uma ou mais instruções, tínhamos que digitá- las novamente;• Tal solução é ineficiente, considerando que quanto maior o número de repetições maior será o número de linhas de código; • Solução: utilizar estruturas de repetição;
    • Estruturas de Repetição• São estruturas sintáticas que permitem a repetição de um trecho de algoritmo em uma determinada quantidade de iterações ou de acordo com um critério (condição);• Em Portugol, temos 3 estruturas de repetição: enquanto...faca, repita...até, para...faca;
    • Enquanto...faca• Nesta estrutura, uma condição lógica é avaliada. Caso a condição seja atendida, sua lista de instruções será executada;• A execução da lista é repetida até que a avaliação da condição retorne FALSO;
    • Enquanto...faca• Utilizamos as palavras reservadas ENQUANTO, FACA e FIMENQUANTO para formar o laço de repetição;• Forma geral: enquanto (condição) faca // lista de instruções fimenquanto
    • Enquanto...faca• Exemplo: Algoritmo que lê vários números positivos e exibe a raiz quadrada de cada um; Algoritmo "exemplo_enquanto" Var numero: real Inicio Leia(numero) Enquanto (numero>=0) faca Escreval(numero^0.5) Leia(numero) Fimenquanto Fimalgoritmo
    • Enquanto...faca• Exemplo: Algoritmo que escreve números entre 1 e 10; Algoritmo "exemplo_enquanto" Var numero: inteiro Inicio Numero <- 1 Enquanto (numero<=10) faca Escreval(numero) Numero <- numero + 1 Fimenquanto Fimalgoritmo
    • Exercícios• Faça um algoritmo que lê repetidamente números inteiros positivos. O algoritmo deverá encerrar a leitura dos valores quando um número negativo for digitado;
    • Exercícios• Faça um algoritmo que lê o sexo de 10 pessoas (M ou F). O mesmo deverá contar e exibir a quantidade de homens e mulheres;
    • Exercícios• Faça um algoritmo que lê repetidamente a altura de várias pessoas, até que uma altura negativa seja digitada. O algoritmo deverá calcular e exibir a média das alturas lidas;
    • Exercícios• Faça um algoritmo que receba os placares de 10 partidas entre Sport e Flamengo. Baseado nos placares lidos, o algoritmo deverá apresentar o nome do time que venceu mais confrontos.