Algoritmos e programação - Aula 6

9,240 views
8,926 views

Published on

Slides referentes a 6ª aula da disciplina de Algoritmos e Programação, realizada no dia 19/02/2011

Published in: Technology
0 Comments
2 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
9,240
On SlideShare
0
From Embeds
0
Number of Embeds
44
Actions
Shares
0
Downloads
250
Comments
0
Likes
2
Embeds 0
No embeds

No notes for slide

Algoritmos e programação - Aula 6

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 6
  2. 2. Sumário <ul><li>Estrutura condicional (continuação); </li></ul><ul><li>Comando de seleção múltipla (Escolha...caso); </li></ul>
  3. 3. Exemplo <ul><li>Algoritmo: Controle de entrada em boate. Tal algoritmo avisa se uma pessoa pode entrar ou não, e quanto deverá pagar para entrar. </li></ul><ul><ul><li>Homens e mulheres abaixo de 18 anos não podem entrar. Homens pagam R$ 20,00. Mulheres pagam R$ 10,00 </li></ul></ul>
  4. 4. Exemplo <ul><li>algoritmo “entrada_boate” </li></ul><ul><li>var sexo: literal </li></ul><ul><li>idade: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>escreval(“Digite sexo e idade”) </li></ul><ul><li>leia(sexo) </li></ul><ul><li>leia(idade) </li></ul><ul><li>se (idade < 18) entao </li></ul><ul><li>escreval(“Entrada proibida”) </li></ul><ul><li>senao </li></ul><ul><li>se (sexo=“M”) </li></ul><ul><li> escreva(“Entrada liberada: R$ 20,00”) </li></ul><ul><li>fimse </li></ul><ul><li>se (sexo=“F”) </li></ul><ul><li> escreva(“Entrada liberada: R$ 10,00”) </li></ul><ul><li>fimse </li></ul><ul><li>fimalgoritmo </li></ul>
  5. 5. Exercício <ul><li>Elaborar um algoritmo que efetue o cálculo do reajuste de salário de um funcionário. Considere que o funcionário deverá receber um reajuste de 15% (0.15) se seu salário seja menor ou igual a 500. Caso contrario, seu reajuste será de 10% (0.1). </li></ul>
  6. 6. Comando de seleção múltipla <ul><li>Em algumas situações é necessário termos várias soluções ligadas a repostas diferentes; </li></ul><ul><li>O comando se nos permite implementar tais situações, porém de forma limitada e, em alguns casos, ineficiente: </li></ul><ul><ul><li>Imagine implementar 100 estruturas do tipo se para 100 condições diferentes! </li></ul></ul><ul><ul><li>Tal comando obriga o programador a escrever várias linhas de código; </li></ul></ul>
  7. 7. Comando de seleção múltipla <ul><li>Para várias condições, podemos utilizar o comando de seleção múltipla escolha ; </li></ul><ul><li>escolha expressao </li></ul><ul><li>caso resultado_1 </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>caso resultado_2 </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>... </li></ul><ul><li>outrocaso </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>fimescolha </li></ul>
  8. 8. Comando de seleção múltipla <ul><li>As palavras reservadas escolha e fimescolha delimitam a região que fará a seleção múltipla; </li></ul><ul><li>O comando escolha seleciona uma expressão ou variável para ser comparada com os valores especificados nos comandos caso ; </li></ul><ul><li>O comando caso tem o funcionamento similar ao comando se , visto anteriormente; </li></ul><ul><li>O comando outrocaso tem o funcionamento similar ao comando senao , visto anteriormente; </li></ul>
  9. 9. Comando de seleção múltipla <ul><li>Exemplo: </li></ul><ul><li>algoritmo “exemplo_caso” </li></ul><ul><li>var sexo: literal </li></ul><ul><li>inicio </li></ul><ul><li>escreval(“Digite seu sexo (M ou F)”) </li></ul><ul><li>leia(sexo) </li></ul><ul><li>escolha(sexo) </li></ul><ul><li>caso “M” </li></ul><ul><li>escreval(“O usuário é Homem”) </li></ul><ul><li>caso “F” </li></ul><ul><li>escreval(“O usuário é Mulher”) </li></ul><ul><li>fimescolha </li></ul><ul><li>fimalgoritmo </li></ul>
  10. 10. Comando de seleção múltipla <ul><li>Exemplo 2: </li></ul><ul><li>algoritmo “menor_idade” </li></ul><ul><li>var idade: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>escreval(“Digite sua idade:”) </li></ul><ul><li>leia(idade) </li></ul><ul><li>escolha(idade) </li></ul><ul><li>caso 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17 </li></ul><ul><li>escreval(“Menor de idade”) </li></ul><ul><li>outrocaso </li></ul><ul><li>escreval(“Maior de idade”) </li></ul><ul><li>fimescolha </li></ul><ul><li>fimalgoritmo </li></ul>
  11. 11. Exercícios <ul><li>Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número não corresponder a um dia da semana, é exibida uma mensagem de erro; </li></ul><ul><li>Faça um algoritmo que lê uma letra e informa se a mesma é uma vogal ou consoante. A mesma deverá exibir uma mensagem de erro no caso de digitação incorreta; </li></ul>
  12. 12. Exercícios <ul><li>Faça um algoritmo (utilizando o comando escolha) que, baseado no código digitado pelo usuário, retorne o nome e valor do produto. </li></ul><ul><li>Sabendo que </li></ul><ul><ul><li>001 – Parafuso (R$ 0,15) </li></ul></ul><ul><ul><li>002 – Porca (R$ 0,05) </li></ul></ul><ul><ul><li>003 – Prego (R$ 0,10) </li></ul></ul><ul><ul><li>004 – Martelo (R$ 40,00) </li></ul></ul><ul><ul><li>005 – Tomada (R$ 3,00) </li></ul></ul>
  13. 13. Exercícios <ul><li>Faça um algoritmo que receba dois números, um operador matemático (+,-,*,/) e efetue o cálculo matemático baseado no operador digitado. O resultado deverá ser exibido em seguida. Utilize o comando escolha . </li></ul><ul><li>Exemplo: </li></ul><ul><ul><li>Caso “+” </li></ul></ul><ul><ul><li>resultado <- valor1 + valor2 </li></ul></ul><ul><ul><li>Caso “-” </li></ul></ul><ul><ul><li>... </li></ul></ul>
  14. 14. Exercícios <ul><li>Elabore um algoritmo que, dada a idade válida de um nadador, classifique-o em uma das seguintes categorias: </li></ul><ul><ul><li>Não aceito: 0 a 4 anos </li></ul></ul><ul><ul><li>Infantil: 5 a 10 anos </li></ul></ul><ul><ul><li>Juvenil: 11 a 17 anos </li></ul></ul><ul><ul><li>Sênior: 17 a 20 anos </li></ul></ul>

×