Algoritmos e Programação - Aula 5
Upcoming SlideShare
Loading in...5
×
 

Algoritmos e Programação - Aula 5

on

  • 2,924 views

Algoritmos e Programação - Aula 5

Algoritmos e Programação - Aula 5

Statistics

Views

Total Views
2,924
Views on SlideShare
2,881
Embed Views
43

Actions

Likes
1
Downloads
50
Comments
0

2 Embeds 43

http://ead.unipe.br 41
https://twitter.com 2

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

Algoritmos e Programação - Aula 5 Algoritmos e Programação - Aula 5 Presentation Transcript

  • Profº Thyago Maia Algoritmos e Programação Aula 5
  • Sumário
    • Estruturas Condicionais
  • Estruturas Condicionais
    • Também podemos implementar estruturas condicionais com mais de uma condição (expressão);
    • Subexpressões podem formar uma única expressão a partir do uso dos operadores E ou OU ;
    • Para sabermos se determinada expressão será verdadeira ou falsa, seguimos a mesma lógica vista nas aulas de linearização e modularização;
  • Exemplo Algoritmo “exemplo_genero” Var sexo: literal idade: inteiro Inicio escreva(“Digite seu sexo (M ou F): ”) leia(sexo) escreva(“Digite sua idade: ”) leia(idade) se((sexo=“M”) e (idade=18))entao escreva(“Você já se alistou nas forças armadas?”) fimse fimalgoritmo
  • Exemplo 2 Algoritmo “exemplo_genero” Var estado: literal Inicio escreva(“Digite seu estado (PE, PB, RJ ou SP): ”) leia(estado) se((estado=“PE”) ou (estado=“PB”))entao escreva(“Você é nordestino”) fimse se((estado=“RJ”) ou (estado=“SJ”))entao escreva(“Você é do sudeste”) fimse fimalgoritmo
  • Exercícios
    • Faça um algoritmo que lê um número inteiro e verifica se o mesmo é positivo ou negativo;
  • Exercícios
    • Faça um algoritmo que receba três notas de um determinado aluno, calcula sua média e informa se o mesmo está aprovado ou reprovado;
      • A média final deve ser superior a 6 para que o aluno seja aprovado;
  • Exercícios
    • Faça um algoritmo que verifica quanto cada pessoa deverá pagar para entrar em um cinema. O algoritmo deverá solicitar o sexo e a idade do indivíduo. As condições de pagamento são as seguintes:
      • O ingresso custa R$ 10,00 para pessoas maiores de 17 anos;
      • Mulheres menores de 18 anos pagam meia entrada;
      • Homens menores de 18 anos pagam R$ 7,00;
  • Exercícios
    • Faça um algoritmo para controle de entrada em uma boate. Tal algoritmo deverá avisar se uma pessoa pode entrar ou não, e quanto deverá pagar para entrar.
      • Homens e mulheres abaixo de 18 anos não podem entrar;
      • Mulheres pagam R$ 10,00;
      • Homens pagam R$ 20,00;
  • Comando de Seleção Múltipla
    • Em algumas situações é necessário analisar mais que duas condições;
    • O comando se nos permite implementar tais situações, porém de forma limitada e, em alguns casos, ineficiente:
      • Imagine implementar 100 estruturas se para 100 condições diferentes!
      • Tal comando obriga o programador a escrever várias linhas de código;
  • Comando de Seleção Múltipla
    • Para várias condições, podemos utilizar o comando de seleção múltipla escolha ;
    • Sintaxe:
    escolha (variavel) Caso valor_1 // Instruções que serão executadas caso // a condição seja verdadeira Caso valor_2 // Instruções que serão executadas caso // a condição seja falsa Outrocaso // Instruções que serão executadas se // nenhuma condição anterior seja atendida fimescolha
  • Comando de Seleção Múltipla
    • As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional;
    • Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso ;
    • O caso tem funcionamento similar ao se ;
    • O outrocaso tem funcionamento similar ao senao , visto anteriormente;
  • Exemplo Algoritmo “exemplo_caso” Var sexo: literal Inicio escreval(“Digite seu sexo (M ou F): ”) leia(sexo) escolha(sexo) caso “M” escreval(“O usuário é homem”) caso “F” escreval(“O usuário é mulher”) outrocaso escreval(“Erro de caractere!”) fimescolha fimalgoritmo
  • Exemplo 2 Algoritmo “exemplo_caso_2” Var time: literal Inicio escreval(“Digite seu time: ”) leia(time) escolha(time) caso “sport” escreval(“Parabéns!!!”) outrocaso escreval(“Meus pêsames!”) fimescolha fimalgoritmo
  • Exercícios
    • Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma mensagem de erro;
  • Exercícios
    • Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário. O resultado deverá ser exibido em seguida;