• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Algoritmos e programação - Aula 4
 

Algoritmos e programação - Aula 4

on

  • 6,978 views

Slides referentes a 4ª aula da disciplina de Algoritmos e Programação, realizada no dia 12/02/2011

Slides referentes a 4ª aula da disciplina de Algoritmos e Programação, realizada no dia 12/02/2011

Statistics

Views

Total Views
6,978
Views on SlideShare
6,935
Embed Views
43

Actions

Likes
4
Downloads
231
Comments
0

4 Embeds 43

http://thyagomaia.net 23
http://algoritmos.thyagomaia.net 11
http://www.algoritmos.thyagomaia.net 7
http://ead.unipe.br 2

Accessibility

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Algoritmos e programação - Aula 4 Algoritmos e programação - Aula 4 Presentation Transcript

    • Algoritmos e Programação Thyago Maia Tavares de Farias Aula 4
    • Sumário
      • Linhas de comentário;
      • Comandos de entrada e saída (E/S ou I/O)
    • Linhas de comentário
      • Informação textual para documentação de programa;
      • Ajudam a organizar o algoritmo, tornando-o mais legível;
      • São representados por duas barras normais (//). Todo texto digitado após as duas barras é considerado comentário;
      • Comentários não são compilados;
    • Linhas de comentário
      • Exemplo:
        • // Algoritmo que utiliza variável lógica
        • Algoritmo “teste”
        • Var ligado: logico
        • Inicio
        • // Insere verdadeiro na variável
        • ligado <- Verdadeiro
        • fimalgoritmo
    • Comandos de entrada e saída
      • Comandos escreva e escreval
        • Utilizados para escrever mensagens ou valores de variáveis;
          • escreva escreve algo e mantém o cursor na mesma linha
          • Escreval escreve algo e pula uma linha
        • Ex.:
          • escreva(“Minha primeira mensagem”)
          • escreval(idade)
    • Comandos de entrada e saída
      • Exemplo:
        • Algoritmo “escreve_mensagem”
        • Var
        • Inicio
        • escreva(“Meu algoritmo”)
        • fimalgoritmo
    • Comandos de entrada e saída
      • Exemplo:
        • Algoritmo “le_nome”
        • Var nome: literal
        • Inicio
        • nome <- “Thyago Maia”
        • escreval(“Seu nome é ”, nome)
        • fimalgoritmo
    • Comandos de entrada e saída
      • Comandos leia
        • Utilizado para ler um valor digitado pelo usuário;
        • Ex.:
          • leia(nome)
          • leia(idade)
          • Leia(altura)
          • Leia(distancia)
    • Comandos de entrada e saída
      • Exemplo:
        • Algoritmo “escreve_mensagem_e_variavel”
        • Var nome: literal
        • Inicio
        • escreval(“Digite seu nome:”)
        • leia(nome)
        • escreval(“Seu nome é:”)
        • escreval(nome)
        • fimalgoritmo
    • Comandos de entrada e saída
      • Exemplo:
        • Algoritmo “conta_bancaria”
        • Var agencia: literal
        • conta_corrente: literal
        • nome: literal
        • Inicio
        • escreval(“Digite seu nome:”)
        • leia(nome)
        • escreval(“Digite sua agência:”)
        • leia(agencia)
        • escreval(“Digite sua conta:”)
        • leia(conta_corrente)
        • fimalgoritmo
    • Exercícios
      • Somando dois valores:
        • Escreva um algoritmo que tenha duas variáveis inteiras. As mesmas deverão ter os valores 5 e 7, respectivamente. Faça com que o algoritmo some as duas variáveis e demonstre o resultado;
      • Uma agenda simples:
        • Escreva um algoritmo que leia o nome, telefone, endereço e CEP digitados pelo usuário e escreva os mesmos na tela. Utilize mensagens solicitando a digitação de cada valor;
    • Exemplo
        • Algoritmo “calcula_media”
        • Var nome: literal
        • nota_1, nota_2, media: real
        • Inicio
        • escreval(“Digite o nome do aluno:”)
        • leia(nome)
        • escreval(“1ª nota do aluno”)
        • leia(nota_1)
        • escreval(“2ª nota do aluno”)
        • leia(nota_2)
        • media <- (nota_1 + nota_2) / 2
        • escreval(“Média final do aluno ”, nome)
        • escreval(media)
        • fimalgoritmo
    • Exercício
      • Escreva um algoritmo que calcule a área do quadrado. O usuário deverá digitar o lado de um quadrado (o algoritmo deverá solicitar que o usuário o faça) e o algoritmo deverá exibir o resultado.
        • Área do quadrado = lado ^ 2 (lado elevado ao quadrado)
    • Exercício
      • Faça um algoritmo que leia o nome de um piloto, uma distância percorrida em km e o tempo que o piloto levou para percorrê-la (em horas). O algoritmo deverá calcular a velocidade média e exibir a seguinte mensagem:
        • A velocidade média do piloto * foi **
      • Velocidade Média = Distância/Tempo
    • Exercício
      • Escreva um algoritmo que leia dois números inteiros e exiba o resto da divisão entre eles.
      • Escreva um algoritmo que leia dois números reais, calcule e exiba:
        • A soma destes valores
        • O produto deles
        • O quociente entre eles
    • Exercício
      • Escreva um algoritmo que lê três valores e calcula a área do trapézio.
    • Exercício
      • Faça um algoritmo que determine o volume de uma caixa cilíndrica. O raio e a altura da caixa devem ser fornecidos pelo usuário.
      • PI = 3.14 (O visualg substitui a vírgula por ponto!)