Algoritmos e programação - Aula 4

9,037 views
8,736 views

Published on

Slides referentes a 4ª aula da disciplina de Algoritmos e Programação, realizada no dia 12/02/2011

0 Comments
5 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
9,037
On SlideShare
0
From Embeds
0
Number of Embeds
48
Actions
Shares
0
Downloads
322
Comments
0
Likes
5
Embeds 0
No embeds

No notes for slide

Algoritmos e programação - Aula 4

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 4
  2. 2. Sumário <ul><li>Linhas de comentário; </li></ul><ul><li>Comandos de entrada e saída (E/S ou I/O) </li></ul>
  3. 3. Linhas de comentário <ul><li>Informação textual para documentação de programa; </li></ul><ul><li>Ajudam a organizar o algoritmo, tornando-o mais legível; </li></ul><ul><li>São representados por duas barras normais (//). Todo texto digitado após as duas barras é considerado comentário; </li></ul><ul><li>Comentários não são compilados; </li></ul>
  4. 4. Linhas de comentário <ul><li>Exemplo: </li></ul><ul><ul><li>// Algoritmo que utiliza variável lógica </li></ul></ul><ul><ul><li>Algoritmo “teste” </li></ul></ul><ul><ul><li>Var ligado: logico </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>// Insere verdadeiro na variável </li></ul></ul><ul><ul><li>ligado <- Verdadeiro </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  5. 5. Comandos de entrada e saída <ul><li>Comandos escreva e escreval </li></ul><ul><ul><li>Utilizados para escrever mensagens ou valores de variáveis; </li></ul></ul><ul><ul><ul><li>escreva escreve algo e mantém o cursor na mesma linha </li></ul></ul></ul><ul><ul><ul><li>Escreval escreve algo e pula uma linha </li></ul></ul></ul><ul><ul><li>Ex.: </li></ul></ul><ul><ul><ul><li>escreva(“Minha primeira mensagem”) </li></ul></ul></ul><ul><ul><ul><li>escreval(idade) </li></ul></ul></ul>
  6. 6. Comandos de entrada e saída <ul><li>Exemplo: </li></ul><ul><ul><li>Algoritmo “escreve_mensagem” </li></ul></ul><ul><ul><li>Var </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>escreva(“Meu algoritmo”) </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  7. 7. Comandos de entrada e saída <ul><li>Exemplo: </li></ul><ul><ul><li>Algoritmo “le_nome” </li></ul></ul><ul><ul><li>Var nome: literal </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>nome <- “Thyago Maia” </li></ul></ul><ul><ul><li>escreval(“Seu nome é ”, nome) </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  8. 8. Comandos de entrada e saída <ul><li>Comandos leia </li></ul><ul><ul><li>Utilizado para ler um valor digitado pelo usuário; </li></ul></ul><ul><ul><li>Ex.: </li></ul></ul><ul><ul><ul><li>leia(nome) </li></ul></ul></ul><ul><ul><ul><li>leia(idade) </li></ul></ul></ul><ul><ul><ul><li>Leia(altura) </li></ul></ul></ul><ul><ul><ul><li>Leia(distancia) </li></ul></ul></ul>
  9. 9. Comandos de entrada e saída <ul><li>Exemplo: </li></ul><ul><ul><li>Algoritmo “escreve_mensagem_e_variavel” </li></ul></ul><ul><ul><li>Var nome: literal </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>escreval(“Digite seu nome:”) </li></ul></ul><ul><ul><li>leia(nome) </li></ul></ul><ul><ul><li>escreval(“Seu nome é:”) </li></ul></ul><ul><ul><li>escreval(nome) </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  10. 10. Comandos de entrada e saída <ul><li>Exemplo: </li></ul><ul><ul><li>Algoritmo “conta_bancaria” </li></ul></ul><ul><ul><li>Var agencia: literal </li></ul></ul><ul><ul><li>conta_corrente: literal </li></ul></ul><ul><ul><li>nome: literal </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>escreval(“Digite seu nome:”) </li></ul></ul><ul><ul><li>leia(nome) </li></ul></ul><ul><ul><li>escreval(“Digite sua agência:”) </li></ul></ul><ul><ul><li>leia(agencia) </li></ul></ul><ul><ul><li>escreval(“Digite sua conta:”) </li></ul></ul><ul><ul><li>leia(conta_corrente) </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  11. 11. Exercícios <ul><li>Somando dois valores: </li></ul><ul><ul><li>Escreva um algoritmo que tenha duas variáveis inteiras. As mesmas deverão ter os valores 5 e 7, respectivamente. Faça com que o algoritmo some as duas variáveis e demonstre o resultado; </li></ul></ul><ul><li>Uma agenda simples: </li></ul><ul><ul><li>Escreva um algoritmo que leia o nome, telefone, endereço e CEP digitados pelo usuário e escreva os mesmos na tela. Utilize mensagens solicitando a digitação de cada valor; </li></ul></ul>
  12. 12. Exemplo <ul><ul><li>Algoritmo “calcula_media” </li></ul></ul><ul><ul><li>Var nome: literal </li></ul></ul><ul><ul><li>nota_1, nota_2, media: real </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>escreval(“Digite o nome do aluno:”) </li></ul></ul><ul><ul><li>leia(nome) </li></ul></ul><ul><ul><li>escreval(“1ª nota do aluno”) </li></ul></ul><ul><ul><li>leia(nota_1) </li></ul></ul><ul><ul><li>escreval(“2ª nota do aluno”) </li></ul></ul><ul><ul><li>leia(nota_2) </li></ul></ul><ul><ul><li>media <- (nota_1 + nota_2) / 2 </li></ul></ul><ul><ul><li>escreval(“Média final do aluno ”, nome) </li></ul></ul><ul><ul><li>escreval(media) </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  13. 13. Exercício <ul><li>Escreva um algoritmo que calcule a área do quadrado. O usuário deverá digitar o lado de um quadrado (o algoritmo deverá solicitar que o usuário o faça) e o algoritmo deverá exibir o resultado. </li></ul><ul><ul><li>Área do quadrado = lado ^ 2 (lado elevado ao quadrado) </li></ul></ul>
  14. 14. Exercício <ul><li>Faça um algoritmo que leia o nome de um piloto, uma distância percorrida em km e o tempo que o piloto levou para percorrê-la (em horas). O algoritmo deverá calcular a velocidade média e exibir a seguinte mensagem: </li></ul><ul><ul><li>A velocidade média do piloto * foi ** </li></ul></ul><ul><li>Velocidade Média = Distância/Tempo </li></ul>
  15. 15. Exercício <ul><li>Escreva um algoritmo que leia dois números inteiros e exiba o resto da divisão entre eles. </li></ul><ul><li>Escreva um algoritmo que leia dois números reais, calcule e exiba: </li></ul><ul><ul><li>A soma destes valores </li></ul></ul><ul><ul><li>O produto deles </li></ul></ul><ul><ul><li>O quociente entre eles </li></ul></ul>
  16. 16. Exercício <ul><li>Escreva um algoritmo que lê três valores e calcula a área do trapézio. </li></ul>
  17. 17. Exercício <ul><li>Faça um algoritmo que determine o volume de uma caixa cilíndrica. O raio e a altura da caixa devem ser fornecidos pelo usuário. </li></ul><ul><li>PI = 3.14 (O visualg substitui a vírgula por ponto!) </li></ul>

×