• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Algoritmos e Programação - 2013.1 - Aula 7
 

Algoritmos e Programação - 2013.1 - Aula 7

on

  • 702 views

Algoritmos e Programação - 2013.1 - Aula 7

Algoritmos e Programação - 2013.1 - Aula 7

Statistics

Views

Total Views
702
Views on SlideShare
702
Embed Views
0

Actions

Likes
0
Downloads
25
Comments
0

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Adobe PDF

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Algoritmos e Programação - 2013.1 - Aula 7 Algoritmos e Programação - 2013.1 - Aula 7 Presentation Transcript

    • Algoritmos e Programação Prof. Thyago Prof.º Thyago Maia 2013.1
    • Aula 7Objetivos • Apresentar as estruturas de  p ç repetição • Apresentar a estrutura de  repetição  enquanto...faca ti ã t f 2
    • Enquanto...facaEnquanto faca
    • Enquanto...faca q• Nesta estrutura, uma expressão lógica é  avaliada. Se a mesma for verdadeira, uma lista  de comandos é executada;• A execução da lista se repetirá até que a A execução da lista se repetirá até que a  avaliação da condição resulte em FALSO;• Também é uma estrutura de repetição,  semelhante à estrutura repita...ate; semelhante à estrutura repita...ate;• Difere da estrutura repita...ate na execução da  lista, que pode ser executada ou não; li t d t d ã 4
    • Enquanto...faca q• Utilizamos as palavras reservadas enquanto e  faca para formar o laço de repetição; p ç p ç• F Forma geral: lenquanto (condição) faca // Lista de instruçõesfimenquanto 5
    • Enquanto...faca q• Exemplo ‐ Algoritmo que lê diversos números  p positivos e escreve o dobro de cada um:algoritmo “comEnquanto”var numero: realinicio leia(numero) enquanto (numero >= 0) faca escreval(numero * 2) l( leia(numero) fimenquantofimalgoritmo 6
    • Enquanto...faca q• Exemplo 2 ‐ Algoritmo que escreve os  números entre 1 e 10:algoritmo “Mostra10”var numero: inteiroinicio numero <- 1 enquanto (numero <= 10) faca escreva(numero) numero <- numero + 1 // contador fimenquantofimalgoritmo 7
    • Estruturas de Repetição p ç• Enquanto...faca – Atenção: Cuidado com laços infinitos! Devemos  nos certificar que em algum momento a expressão  nos certificar que em algum momento a expressão lógica próxima a palavra reservada enquanto será  FALSA! 8
    • Estruturas de Repetição p ç• Exemplo ‐ Algoritmo com laço infinito:algoritmo “lacoInfinito”var contador: inteiroinicio enquanto ( q (contador < 10) faca ) contador <- 1 escreva(contador) contador <- contador + 1 fimenquantofimalgoritmo 9
    • Exercícios
    • Exercícios• Faça um algoritmo que receba números  q g inteiros e, enquanto um número negativo não  for digitado, verifica se cada número é menor  que 5; que 5;• Faça um algoritmo que sempre recebe  números pares. Caso receba um número  números pares. Caso receba um número ímpar, sua execução deverá ser encerrada; 11
    • Exercícios• Faça um algoritmo que receba vários números  ( q inteiros  (enquanto o número ‐100 não for  digitado). O mesmo deverá exibir o maior  número digitado; número digitado; 12
    • Exercícios• Faça um algoritmo que lê a idade de várias pessoas,  até que uma idade negativa seja digitada. O  algoritmo deverá calcular e exibir a quantidade de  pessoas, de acordo com as faixas etárias  apresentadas na tabela abaixo: FAIXA ETÁRIA IDADE 1ª <= 15 anos 2ª De 16 a 30 anos 3ª De 31 a 45 anos 4 4ª De 46 a 60 anos De 46 a 60 anos 5ª > 60 anos 13
    • Explore o assunto!Explore o assunto!
    • Explore o assunto! p• Referências – Introdução aos  ç algoritmos(TONET, B.,  KOLIVER, C.): Tópico 14 e  , ) p Exercícios da Página 43; – Disponível em Disponível em   http://www.claudiorodol fo.com/ftc/ap/manual_vi fo com/ftc/ap/manual vi sualg.pdf 15
    • Explore o assunto! p• Referências – Fundamentos da  programação de  computadores  p (ASCENCIO, A. F. G.,  CAMPOS, E. A. V.):  , ) Exercícios Propostos,  p g páginas 140 a 144; ; 16