Your SlideShare is downloading. ×
Algoritmos e Programação - 2013.1 - Aula 4
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Algoritmos e Programação - 2013.1 - Aula 4

534

Published on

Published in: Technology
0 Comments
2 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
534
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
28
Comments
0
Likes
2
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. Algoritmos e Programação Prof. Thyago Prof.º Thyago Maia 2013.1
  • 2. Aula 4Objetivos • Apresentar as estruturas  condicionais 2
  • 3. Estruturas CondicionaisEstruturas Condicionais
  • 4. Estruturas Condicionais• Na vida real tomamos decisões a todo momento,  baseadas em escolhas;• Em algoritmos, chamamos tais decisões de Em algoritmos, chamamos tais decisões de  condições;• Associada a uma condição, existirá uma possível  alternativa; alternativa • Exemplo: Se o Sport não vencer o Santa Cruz na próxima  partida, seu técnico será demitido; partida seu técnico será demitido; 4
  • 5. Estruturas Condicionais• Analisando o exemplo anterior: • A condição do exemplo: “o Sport não vencer o  ç p p Santa Cruz”; • Possíveis decisões baseadas na condição: Sim Possíveis decisões baseadas na condição: Sim  (Verdadeiro) ou não (Falso); • Logo condições geram respostas lógicas! Logo, condições geram respostas lógicas!  • Se a condição for verdadeira, a ação “demitir o  técnico será executada; técnico” será executada; • Caso contrário (senão), o técnico continuará no  Sport; 5
  • 6. Estruturas Condicionais• Para criarmos estruturas condicionais simples  g p em Portugol, utilizamos as palavras reservadas  se, entao e fimse;• Sintaxe:Se (condicao) entao // Instruçõesfimse 6
  • 7. Estruturas Condicionais• Exemplo:Algoritmo “exemplo_se”Var numero: inteiroInicio escreva( Digite escreva(“Digite um número: ”) ) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) fimsefimalgoritmo 7
  • 8. Estruturas Condicionais• Exemplo:Algoritmo “exemplo_senha”Var senha: literalInicio escreva( Digite escreva(“Digite a senha: ”) ) leia(senha) se(senha= soueu123 )entao se(senha=“soueu123”)entao escreva(“Acesso liberado!”) fimsefimalgoritmo 8
  • 9. Estruturas Condicionais• Para criarmos estruturas condicionais com  pç g duas opções de escolha em Portugol,  utilizamos as palavras reservadas se, entao,  senao e fimse; e fimse;Se Sintaxe:• (condicao) entao // Instruções que serão executadas se õ ã d // a condição for verdadeiraSenao // Instruções que serão executadas se // a condição for falsafimse 9
  • 10. Estruturas Condicionais• Exemplo:Algoritmo “exemplo_se_senao” _ _Var numero: inteiroInicio escreva(“Digite um número: ”) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) senao escreva(“O número é maior ou i (“O ú i igual a l3!”) fimsefimalgoritmo 10
  • 11. Estruturas Condicionais• Exemplo:Algoritmo “exemplo_senha_2” g pVar senha: literalInicio escreva(“Digite a senha: ”) leia(senha) se(senha=“soueu123”)entao escreva(“Acesso lib (“A liberado!”) d !”) senao escreva(“Acesso proibido!”) fimsefimalgoritmo 11
  • 12. Estruturas Condicionais• Exemplo: Faça um algoritmo que lê um  p número inteiro e verifica se o mesmo é par ou  ímpar; 12
  • 13. Estruturas CondicionaisAlgoritmo “par_impar”Var numero: inteiroInicio escreva( Digite escreva(“Digite um numero: ”) ) leia(numero) se(numero % 2 = 0)entao escreva(“O número é PAR”) senao escreva(“O número é ÍMPAR”) fimsefimalgoritmo 13
  • 14. Explore o assunto!Explore o assunto!
  • 15. Explore o assunto! p• Referências – Introdução aos  ç algoritmos(TONET, B.,  KOLIVER, C.): Tópico 10 e  , ) p Exercícios da Página 42; – Disponível em Disponível em   http://www.claudiorodol fo.com/ftc/ap/manual_vi fo com/ftc/ap/manual vi sualg.pdf 15
  • 16. Explore o assunto! p• Referências – Fundamentos da  programação de  computadores  p (ASCENCIO, A. F. G.,  CAMPOS, E. A. V.):  , ) Exercícios Propostos,  p g páginas 88, 89, 90, 91,  , , , , 92; 16

×