Your SlideShare is downloading. ×
0
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
6 Escritura De Algoritmos Programas
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

6 Escritura De Algoritmos Programas

12,893

Published on

Presentación en la que podemos aprender sobre como realizar un programa mediante el uso de la técnica de pseudocódigo

Presentación en la que podemos aprender sobre como realizar un programa mediante el uso de la técnica de pseudocódigo

Published in: Education
0 Comments
4 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
12,893
On Slideshare
0
From Embeds
0
Number of Embeds
1
Actions
Shares
0
Downloads
372
Comments
0
Likes
4
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. ESCRITURA DE ALGORITMOS Y PROGRAMAS<br />ING. PAULO GUERRA<br />ESCUELA POLITÉCNICA DEL EJÉRCITO<br />INGENIERIA GEOGRÁFICA Y MESIO AMBIENTE<br />
  • 2. Programación del algoritmo <br />Una vez determinado el algoritmo hay que escribirlo en un lenguaje de alto nivel. Por eso lo mejor es escribir el algoritmo en un lenguaje restringido que sea fácil de traducir a un lenguaje de alto nivel. <br />El pseudocódigo es una manera de escribir algoritmos de forma poco estricta (con una sintaxis relajada) o estructuras de datos poco detalladas, pero intentando acercar las ideas del algoritmos a estructuras y sintaxis parecidas a las de los lenguajes de alto nivel en los que vamos a programar el algoritmo. <br />
  • 3. Estructura de un programa en pseudocódigo <br />Algoritmo nombre_de_algoritmo<br />Constantes <br />constante = valor <br />Tipos <br />tipo nombre_tipo<br /> tipo campo1<br /> tipo campo2 <br />fin_tipo<br />Variables <br />tipo variable1, variable2<br />Inicio <br />Sentencias <br />Fin <br />
  • 4. Las sentencias serán únicamente de tres tipo: <br />1. Instrucciones de entrada/salida <br />Leer(variable). Pide un valor al usuario y lo almacena en la variable. <br />2.Asignaciones <br />Instrucción simple compuesta por una variable, el símbolo de la asignación (←) y una expresión o literal. Tras ejecutar la instrucción a la variable se le asignará el resultado de la expresión. <br /> Variable ← expresión <br /> Ejemplo: <br /> a ← 2 + 4 * (8+a) <br />3Estructuras de control.descritas a continuación. <br />
  • 5. Estructuras de control <br />Llamaremos estructuras de control a las acciones que tienen como objeto marcar el orden de ejecución de las instrucciones y que van a servirnos para escribir concisamente y sin ambigüedades los algoritmos. <br />Todas las estructuras de control que estudiaremos estarán compuestas de unos elementos básicos (léxico) y una estructura (sintaxis.) <br />
  • 6. Estructuras secuenciales <br />En una estructura secuencial una instrucción sigue a otra en una secuencia lineal. Pseudocódigo <br />Inicio <br /> tarea1 <br /> tarea2 <br /> ... <br /> tarea n <br />Fin <br />Ejemplo: Calcular la nota media de un alumno . <br />nota_teoria * 0.7 + nota_practica *0.3 <br />Pseudocódigo <br />Algoritmo calcula_nota<br />variables <br />real: nota_teoria, nota_practica, nota_final<br />Inicio <br />Leer (nota_teoria) <br />Leer (nota_practica) <br />nota_final ← nota_teoria * 0.7 + nota_practica * 0.3 <br />Escribir (nota_final) <br />Fin <br />
  • 7. Estructuras selectivas <br />Son las que toman una cierta dirección dentro del flujo del programa en función de una condición o el valor de una variable. <br />Tenemos alternativas simples, dobles o multiples<br />Alternativas simples <br />Se realiza una acción o conjunto de acciones si se cumple una determinada condición. Pseudocódigo <br />... <br />Si ( expresion) entonces <br />acciones <br />Fin_si<br />
  • 8. Ejemplo: Ordenar dos números (Leídos dos números escribir por pantalla primero el menor y luego el mayor) Pseudocódigo <br />Algoritmo Ordenar <br />Variables <br />entero a, b, aux<br />Inicio <br />Leer (a) <br />Leer (b) <br />Si (a &gt; b) Entonces <br />aux ← a <br />a ← b <br />b ← aux<br />Fin_si<br />Escribir (a) <br />Escribir (b) <br />Fin <br />
  • 9. Alternativas dobles <br />Si una condición se cumple se realizan unas acciones, si no se cumple la condición se realizan otras. Pseudocódigo <br />... <br />Si ( expresión ) entonces <br /> acciones1 <br />sino <br /> acciones2 <br />Fin_si<br />
  • 10. Ejemplo sencillo: Dado un número, decir si es positivo o negativo. Pseudocódigo <br />Algoritmo Positivo_Negativo<br /> Variables <br /> Entero x<br />Inicio <br /> Leer (x) <br /> Si (x&lt;0) entonces <br /> Escribir (‘Numero negativo’) <br /> sino <br /> Escribir (‘Numero positivo’) <br />Fin_si<br />Fin <br />
  • 11. Estructura Condicional Múltiple<br />Se evalúan en orden una serie de condiciones.<br />Se ejecuta la serie de acciones asociada a la primera condición que se cumpla. Si ninguna de las condiciones se cumple, se ejecuta una serie de acciones alternativas.<br />
  • 12. Alternativas múltiples por casos <br />Dependiendo del valor de una variable se realizan unas acciones u otras. Pseudocódigo <br />... <br />Según_sea (variable) hacer <br />Caso valor1: acciones1 <br />Caso valor2: acciones2 <br />… <br />Caso valorn: accionesn<br />Default: accionesx<br />Fin_según_sea<br />
  • 13. Algoritmo Calculadora <br /> Variables <br /> Entero num1, num2, opcion<br /> Real respuesta<br />Inicio <br /> Escribir ( ‘Ingrese los números’) <br /> Leer (num1) <br /> Leer (num2) <br /> Escribir (‘Seleccione la operación:’) <br /> Escribir (‘(1-Suma/2-Resta’) <br /> Escribir (‘(3-Multiplic./4-División’) <br /> Leer (opcion) <br />Según_sea(opcion) hacer <br /> Caso 1: respuesta &lt;- num1 + num2 <br /> Escribir (respuesta) <br /> Caso 2: respuesta &lt;- num1 - num2 <br /> Escribir (respuesta) <br /> Caso 3: respuesta &lt;- num1 * num2 <br /> Escribir (respuesta) <br /> Caso 4: si(num2==0) entonces<br />Escribir (‘Error… no existe división para 0’) <br /> sino<br /> respuesta &lt;- num1 /num2 <br /> Escribir (respuesta) <br /> fin si<br />Default: Escribir (‘Operación no válida’) <br />Fin_según_sea<br />Fin <br />
  • 14. Estructura Repetitiva mientras<br />Las acciones del cuerpo del bucle se realizan mientras la<br />condición sea verdadera.<br />Se pregunta por la condición al principio. Se deduce entonces<br />que el cuerpo del bucle puede no ejecutarse.<br />
  • 15. Ejemplo mientras<br />Escribir un algoritmo que muestre la tabla de multiplicar del numero 7. Para ello emplee la Estructura Repetitiva Mientras.<br />Algoritmo Calculadora <br /> Variables <br /> Entero M, C<br />Inicio <br /> M ← 0<br />C ← 1<br /> mientras ( C &lt;= 12 ) hacer<br /> M ← C * 7<br /> C ← C + 1<br /> Escribir (M)<br /> Fin mientras<br />FIN<br />
  • 16. Estructura Repetitiva para<br />Las acciones del cuerpo del bucle se realizan un número de<br />veces especificado de antemano.<br />
  • 17. Ejemplo para<br />algoritmo Numeros_del_1_al_10 variables    entero contador inicio    para contador ← 1 hasta 10 hacer       escribir( contador )    fin_para fin<br />
  • 18. Fuentes Consultadas<br />Internet <br />http://mural.uv.es/pausan5/Tema4.pdf<br />http://www.carlospes.com/curso_de_algoritmos/10_03_repetitiva_para.php<br />FUNDAMENTOS DE PROGRAMACION. LIBRO DE PROBLEMAS. Autor: JOYANES AGUILAR, LUIS. Editora: MCGRAW-HILL / INTERAMERICANA. DE ESPAÑA, S.A.. ISBN: 8448107004<br />

×