Balanceig de càrrega PCC
amb Mikrotik
Aquest document ha estat creat per Jordi Clopés Esteban
i està protegit per la llice...
BALANCEIG DE CÀRREGA PCC
En aquest exemple veurem com repartir equitativament la
càrrega entre diferents gateways. El segü...
DEFINIM ADREÇAMENT
#Definim l'adreçament
#ether1 serà la interfície que connecta amb la nostra LAN (192.168.1.0/24)
#ether...
FEM MASQUERADE
#Emmascarem tot el que surti cap a Internet per ether2 i ether3
/ip firewall nat
add chain=srcnat action=ma...
MARQUEM PAQUETS
#Marquem el tràfic que entra des d'Internet per cada interfície d'entrada
/ip firewall mangle
add action=m...
MARQUEM PAQUETS
#Marquem el tràfic que surt cap a Internet per cada interfície de sortida
/ip firewall mangle
add action=m...
MARQUEM PAQUETS
#Marquem les connexions i les repartim equitativament per les gateways.
/ip firewall mangle
add action=mar...
MARQUEM PAQUETS
#Marquem les connexions i els hi donem una marca de routing
per tal que surtin per gateways diferents.
/ip...
DEFINIM LES RUTES
#Creem les rutes que pendran els paquets marcats
/ip route
add check-gateway=ping disabled=no distance=1...
COMPROVACIÓ
Generem el tràfic pertinent i observem com el tràfic és repartit
per les dues interfícies.
FONTS
Balanceo de carga:
http://tamax.com.ar/blog/?p=1216
Load balancing over multiple gateways:
http://wiki.mikrotik.com/...
Upcoming SlideShare
Loading in …5
×

Balanceig de càrrega PCC amb Mikrotik

431 views
357 views

Published on

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
431
On SlideShare
0
From Embeds
0
Number of Embeds
2
Actions
Shares
0
Downloads
24
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Balanceig de càrrega PCC amb Mikrotik

  1. 1. Balanceig de càrrega PCC amb Mikrotik Aquest document ha estat creat per Jordi Clopés Esteban i està protegit per la llicencia Creative Commons by-sa 3.0 Twitter @jordiclopes jordiclopes@gmail.com
  2. 2. BALANCEIG DE CÀRREGA PCC En aquest exemple veurem com repartir equitativament la càrrega entre diferents gateways. El següent exemple anirà alternant les sortides a Internet segons l'adreça origen del host que realitza la connexió. Utilitzarem PCC (Per Client Connect) per repartir equitativament les connexions.
  3. 3. DEFINIM ADREÇAMENT #Definim l'adreçament #ether1 serà la interfície que connecta amb la nostra LAN (192.168.1.0/24) #ether2 connecta amb el primer ADSL (192.168.10.1) #ether3 connecta amb el segon ADSL (192.168.20.1) /ip address add address=192.168.1.1/24 disabled=no interface=ether1 network=192.168.1.0 add address=192.168.10.2/24 disabled=no interface=ether2 network=192.168.10.0 add address=192.168.20.2/24 disabled=no interface=ether3 network=192.168.20.0
  4. 4. FEM MASQUERADE #Emmascarem tot el que surti cap a Internet per ether2 i ether3 /ip firewall nat add chain=srcnat action=masquerade out-interface="ether2" comment="Gateway 192.168.10.1/24" disabled=no add chain=srcnat action=masquerade out-interface="ether3" comment="Gateway 192.168.20.1/24" disabled=no
  5. 5. MARQUEM PAQUETS #Marquem el tràfic que entra des d'Internet per cada interfície d'entrada /ip firewall mangle add action=mark-connection chain=input disabled=no in-interface=ether2 new-connection-mark=WAN1_conn passthrough=yes add action=mark-connection chain=input disabled=no in-interface=ether3 new-connection-mark=WAN2_conn passthrough=yes
  6. 6. MARQUEM PAQUETS #Marquem el tràfic que surt cap a Internet per cada interfície de sortida /ip firewall mangle add action=mark-routing chain=output connection-mark=WAN1_conn disabled=no new-routing-mark=to_WAN1 passthrough=yes add action=mark-routing chain=output connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
  7. 7. MARQUEM PAQUETS #Marquem les connexions i les repartim equitativament per les gateways. /ip firewall mangle add action=mark-connection chain=prerouting disabled=no dst-address-type="" in-interface=ether1 new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address-type= !local add action=mark-connection chain=prerouting disabled=no dst-address-type="" in-interface=ether1 new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address-type= !local
  8. 8. MARQUEM PAQUETS #Marquem les connexions i els hi donem una marca de routing per tal que surtin per gateways diferents. /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=WAN1_conn disabled= no in-interface=ether1 new-routing-mark=to_WAN1 passthrough=yes add action=mark-routing chain=prerouting connection-mark=WAN2_conn disabled= no in-interface=ether1 new-routing-mark=to_WAN2 passthrough=yes
  9. 9. DEFINIM LES RUTES #Creem les rutes que pendran els paquets marcats /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 192.168.10.1 routing-mark=to_WAN1 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 192.168.20.1 routing-mark=to_WAN2 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 192.168.10.1 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 192.168.20.1 scope=30 target-scope=10
  10. 10. COMPROVACIÓ Generem el tràfic pertinent i observem com el tràfic és repartit per les dues interfícies.
  11. 11. FONTS Balanceo de carga: http://tamax.com.ar/blog/?p=1216 Load balancing over multiple gateways: http://wiki.mikrotik.com/wiki/Load_Balancing_over_Multiple_Gateways PCC: http://wiki.mikrotik.com/wiki/PCC Script failover quan una connexió falla: http://wiki.mikrotik. com/wiki/Improved_Load_Balancing_over_Multiple_Gateways_Failover_Script

×