Balanceig de càrrega amb
Mikrotik
Aquest document ha estat creat per Jordi Clopés Esteban
i està protegit per la llicencia...
QUÈ ÉS EL BALANCEIG DE CÀRREGA?
Donades dos o més sortides a Internet podem repartir la
càrrega de les connexions a Intern...
ESQUEMA
BALANCEIG PER PROTOCOL
Podem triar la sortida a Internet d'una connexió en funció del
protocol que utilitza. Per exemple, ...
BALANCEIG PER PROTOCOL
#Definim l'adreçament
#ether1 serà la interfície que connecta amb la nostra LAN (192.168.1.0/24)
#e...
BALANCEIG PER PROTOCOL
#Emmascarem tot el que surti cap a Internet per ether2 i ether3
/ip firewall nat
add chain=srcnat a...
BALANCEIG PER PROTOCOL
#Marquem el tràfic HTTP, SSL, P2P i la resta de tràfic
/ip firewall mangle
add chain=prerouting act...
BALANCEIG PER PROTOCOL
#Enrutem el tràfic cap a els ADSLs en funció de les marques (MANGLE) que hem fet
#prèviament.
/ip r...
COMPROVACIÓ
Generem el tràfic pertinent i observem per quina interfície
(ether2 o ether 3) és enrutat cap a Internet.
Upcoming SlideShare
Loading in …5
×

Balanceig de càrrega amb Mikrotik

374 views
320 views

Published on

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
374
On SlideShare
0
From Embeds
0
Number of Embeds
8
Actions
Shares
0
Downloads
13
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Balanceig de càrrega amb Mikrotik

  1. 1. Balanceig de càrrega amb Mikrotik Aquest document ha estat creat per Jordi Clopés Esteban i està protegit per la llicencia Creative Commons by-sa 3.0 Twitter @jordiclopes jordiclopes@gmail.com
  2. 2. QUÈ ÉS EL BALANCEIG DE CÀRREGA? Donades dos o més sortides a Internet podem repartir la càrrega de les connexions a Internet entre ambdues sortides a Internet, repartint-ho de forma equitativa i aprofitant les dues connexions.
  3. 3. ESQUEMA
  4. 4. BALANCEIG PER PROTOCOL Podem triar la sortida a Internet d'una connexió en funció del protocol que utilitza. Per exemple, podem escollir que el tràfic HTTP surti per l'ADSL 1 i el tràfic P2P per l'ADSL 2.
  5. 5. BALANCEIG PER PROTOCOL #Definim l'adreçament #ether1 serà la interfície que connecta amb la nostra LAN (192.168.1.0/24) #ether2 connecta amb el primer ADSL (192.168.10.1) #ether3 connecta amb el segon ADSL (192.168.20.1) /ip address add address=192.168.1.1/24 disabled=no interface=ether1 network=192.168.1.0 add address=192.168.10.2/24 disabled=no interface=ether2 network=192.168.10.0 add address=192.168.20.2/24 disabled=no interface=ether3 network=192.168.20.0
  6. 6. BALANCEIG PER PROTOCOL #Emmascarem tot el que surti cap a Internet per ether2 i ether3 /ip firewall nat add chain=srcnat action=masquerade out-interface="ether2" comment="Gateway 192.168.10.0/24" disabled=no add chain=srcnat action=masquerade out-interface="ether3" comment="Gateway 192.168.20.0/24" disabled=no
  7. 7. BALANCEIG PER PROTOCOL #Marquem el tràfic HTTP, SSL, P2P i la resta de tràfic /ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark="HTTP Trafico" passthrough=no dst-port=80 protocol=tcp comment="" disabled=no src-address=192. 168.1.0/24 add chain=prerouting action=mark-routing new-routing-mark="SSL Trafico" passthrough=no dst-port=443 protocol=tcp comment="" disabled=no src-address=192.168.1.0/24 add chain=prerouting action=mark-routing new-routing-mark="P2P Trafico" passthrough=no p2p=all-p2p comment="" disabled=no src-address=192.168.1.0/24 add chain=prerouting action=mark-routing new-routing-mark="Unknown Trafico" passthrough=no comment="" disabled=no src-address=192.168.1.0/24
  8. 8. BALANCEIG PER PROTOCOL #Enrutem el tràfic cap a els ADSLs en funció de les marques (MANGLE) que hem fet #prèviament. /ip route add dst-address=0.0.0.0/0 gateway=192.168.20.1 scope=255 target-scope=10 routing- mark="HTTP Trafico" comment="" disabled=no add dst-address=0.0.0.0/0 gateway=192.168.20.1 scope=255 target-scope=10 routing- mark="SSL Trafico" comment="" disabled=no add dst-address=0.0.0.0/0 gateway=192.168.10.1 scope=255 target-scope=10 routing- mark="P2P Trafico" comment="" disabled=no add dst-address=0.0.0.0/0 gateway=192.168.10.1 scope=255 target-scope=10 routing- mark="Unknown Trafico" comment="" disabled=no
  9. 9. COMPROVACIÓ Generem el tràfic pertinent i observem per quina interfície (ether2 o ether 3) és enrutat cap a Internet.

×