Moodle 2.0 Updates Admin Databases

2,386 views

Published on

What's new in Moodle 2.0?

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
2,386
On SlideShare
0
From Embeds
0
Number of Embeds
247
Actions
Shares
0
Downloads
12
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Moodle 2.0 Updates Admin Databases

  1. 1. What’s new in <br />Moodle 2.0<br />
  2. 2. 1. SYSTEM REQUIRMENTS<br />
  3. 3. Moodle 2.0 is a major release and as a<br />result there are increases in the<br />requirements<br />• PHP 5.2.8 is now the maximum <br />version supported. This allows<br />developers to write cleaner code<br />using the more recent features of PHP.<br />
  4. 4. When upgrading to Moodle 2.0 you<br />must have Moodle 1.9 or later. <br />If you are using an earlier version of<br />Moodle you need to upgrade to Moodle<br />1.9 (or later) first<br />
  5. 5. 2. ADMINISTRATIVE IMPROVEMENTS<br />
  6. 6. 1) Enrolments improvements including groups synchronization several major improvements related to guest access, course enrolments, metacourses and groups<br />2) Roles administration interface improvements<br />
  7. 7. 3) Standard Web Services Layer Standard set of core API functions made available via SOAP and XML-RPC<br />4) Development: Site-wide groups<br />5) Admin report plugins can choose where in the admin <br /> tree they are added<br />
  8. 8. 3. DATABASE CONTROL<br />
  9. 9. DB LAYER 2.0 <br />Database access is to be refactored<br />so that, “we can use prepared <br />statements everywhere for increased<br />security and some performance, <br />we put datalib functions in a class to<br />allow better unit tests and remove <br />the need for slashes in userspace. <br />This will cause breakage for 3rd<br />party modules (but fixing them won’t <br />be too hard!)”<br />
  10. 10. ANCIENT DB INSTALL / <br />UPGRADE SYSTEM REMOVED<br />The deprecated system for installing<br />or upgrading database entire used <br />in Moodle &lt; 1.7 will be completely<br />removed, while supporting only the<br />new XML based database scheme<br />introduced in 1.7<br />
  11. 11. For more information email<br />info@synergy-learning.com<br />

×