• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Lista de exercício   resposta
 

Lista de exercício resposta

on

  • 24,673 views

 

Statistics

Views

Total Views
24,673
Views on SlideShare
24,673
Embed Views
0

Actions

Likes
2
Downloads
0
Comments
2

0 Embeds 0

No embeds

Accessibility

Categories

Upload Details

Uploaded via as Adobe PDF

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel

12 of 2 previous next

  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Lista de exercício   resposta Lista de exercício resposta Document Transcript

    • Lista de Exercício – Algoritmos01. Tendo como exemplo o algoritmo desenvolvido, em sala de aula, para solucionar o problema datroca de uma lâmpada. Elabore um algoritmo que mostre os passos necessários para trocar um pneufurado de um carro. Considere a seguinte situação: Trocar o pneu traseiro esquerdo e, antes, verificarse o pneu reserva (step) está com condições de uso.Verifique se o step está em condição de usoSe estiver Então Pegue o macaco Coloque-o debaixo do lado esquerdo traseiro do carro Levante-o, tire o pneu esquerdo Coloque o pneu reservaSenão Procure uma borracharia mais próximaFim do Se02. Considere que uma calculadora comum, de quatro operações está com as teclas de divisão emultiplicação inoperantes. Escreva um algoritmo que resolva as expressões matemática a seguirusando apenas as operações de adição e subtração. A) 12 x 2 A) Algoritmo “A” B) Algoritmo “B” C) Algoritmo “C” D) Algoritmo “D” B) 7 X 3 Var Var Var Var X: Inteiro X: Inteiro X: Inteiro X: Inteiro C) 10÷2 Inicio Inicio Inicio Inicio D) 2² X 12 X 7 X 10 X 2 Escreva (X+X) Escreva (X+X+X) Escreva (X-5) Escreva (X+X) fimalgoritmo fimalgoritmo fimalgoritmo fimalgoritmo03. Encontre os erros das seguintes declarações de variáveis: Endereço, NFilhos: Inteiro __Endereço: caracter, NFilhor: Inteiro_____________________ Idade, X: caracter _____Não possui erros____________________________________________ Peso, R$: real ______ Não possui erros_____________________________________________04. Quais os resultados das expressões aritméticas a seguir? Sendo A=2, B=5, C=3 e D=1. A) ((4 * A) MOD 2) – C = ((4x2) MOD 2) – 3 => (8 MOD 2) -3 => 0 – 3 = -3 B) A ^ 2 * B = 2² x 5 = 20 C) A * B – D = 2x5-1 = 9 D) C – B ^ 2 = 3-5² = 3-25 = -22
    • 05. Faça um algoritmo para calcular uma circunferência. Considere a Formula matemática ( )e = 3.14159. Sendo que o valor será informado pelo usuário. Algoritmo “circunferência” Var r: Inteiro pi:Inteiro área: Inteiro Inicio pi 3,14 área (2*pi*r) Escreva (área) fimalgoritmo06. Três senhoras – Dona Branca, Dona Rosa, Dona Violeta – Passeavam pelo parque quando, DonaRosa disse:-- Não é curioso que estejamos usando vestidos de cores branca, rosa e violeta, embora nenhuma denós esteja usando um vestido de cor igual ao seu próprio nome?-- Uma simples coincidência – respondeu a senhora com vestido violetaQual a cor do vestido de cada senhora? Dona Branca = Vestido Violeta Dona Rosa = Vestido Branco Dona Violeta = Vestido Rosa07. Faça um algoritmo que leia as 3 notas de um aluno e calcule a média final deste aluno. Considerarque a média é ponderada e que o peso das notas é: 2,3 e 5, respectivamente. Algoritmo “Média” Var N1: Inteiro N2:Inteiro N3: Inteiro Media: Interio Inicio Leia(N1) Leia(N2) Leia(N3) Media ((N1*2)+(N2*3)+(N3*5))/3 Escreva (Media) fimalgoritmo08. Escreva um algoritmo que leia 2 números inteiros e mostre o maior deles. Algoritmo “Maior-Menor” Var N1: Inteiro N2:Inteiro Inicio Leia(N1) Leia(N2) Se N1>N2 Então Escreva (N1, “é o maior”) Senão Escreva (N2, “é o maior”) fimalgoritmo
    • 09. Escreva um algoritmo que leia dois números e mostre o produto desses números. Algoritmo “Produto” Var N1: Inteiro N2:Inteiro Prod: Inteiro Inicio Leia(N1) Leia(N2) Prod (N1*N2) Escreva (Prod) fimalgoritmo10. Faça um algoritmo que leia valores para as variáveis A, B e C e mostre o resultado da seguinteexpressão: ( A – B ) * C Algoritmo “Produto” Var A: Inteiro B:Inteiro C: Inteiro Inicio Leia(A) Leia(B) Leia(C) Escreva ((A-B)*C) fimalgoritmo11. Maria quer saber quantos litros de gasolina precisa colocar em seu carro e quanto vai gastar parafazer uma viagem até a casa de sua irmã.Dados extras:- Distância da casa de Maria até sua irmã : 520 km- Seu carro consome 12 litros de gasolina por Km/rodado.- Ela abastece sempre no mesmo posto, onde o preço da gasolina é R$ 1,50 o litro.R$ 9.36012. Faça um algoritmo para ler um número e exibir seu sucessor. Algoritmo “Sucessor” Var A: Inteiro Inicio Leia(A) A A+1 Escreva (A) fimalgoritmo
    • 13. Faça um algoritmo para ler 1 número inteiro e verificar se esse número é par ou impar . Algoritmo “Par-Impar” Var A: Inteiro Inicio Leia(A) Se (A MOD 2) = 0 Então Escreva (“O número é par”) Senão Escreva (“O número é impar”) fimalgoritmo14. Considere o seguinte algoritmo: Algoritmo “_______________” // define o algoritmo Var // indica declaração de variáveis X, Y: inteiro //Declara variável X,Y do tipo Inteiro Z: real // Declara variável Z do tipo real Inicio // Inicia o algoritmo Leia (X) // ler um valor digitado pelo usuário e armazena na variável (X) Escreva (X, “elevado ao cubo = ”, X^3) // Eleva esse valor ao cubo e manda escrever Leia (Y) // Ler outro valor digitado pelo usuário e armazena em (Y) Escreva (X+Y) // escreve o resultado da soma desses dois valores (X+Y) Z X/Y // armazena a divisão desses dois números na variável (Z) Escreva (Z) // manda escrever na tela do usuário Z Z + 1 // agora manda escrever o sucessor desse valor (acrescentando + 1) X (Y+X) MOD 2 (X) receberá a soma de (X+Y) Escreva (X) // escreve para o usuário fim algoritmo // Termina o algoritmoExplique o que está acontecendo em cada linha e qual o resultado de cada ação executada15. Escreva um algoritmo que leia a nota de um aluno e diga se a ele está aprovado ou reprovado.Observação: se a nota for maior ou igual que 60,0 então o aluno está Aprovado, senão está Reprovado. Algoritmo “AP-RP” Var N: Inteiro Inicio Leia(N) Se N >= 60 Então Escreva (“Aprovado”) Senão Escreva (“Reprovado”) fimalgoritmo