Your SlideShare is downloading. ×
Aula 05  Vetores
Upcoming SlideShare
Loading in...5
×

Thanks for flagging this SlideShare!

Oops! An error has occurred.

×
Saving this for later? Get the SlideShare app to save on your phone or tablet. Read anywhere, anytime – even offline.
Text the download link to your phone
Standard text messaging rates apply

Aula 05 Vetores

16,481
views

Published on


0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
16,481
On Slideshare
0
From Embeds
0
Number of Embeds
4
Actions
Shares
0
Downloads
217
Comments
0
Likes
0
Embeds 0
No embeds

Report content
Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
No notes for slide

Transcript

  • 1. Algoritmo 2 – Aula 5Variáveis Compostas Homogêneas
    MA12N
    Prof Eder SamaniegoVillalba
    http://eder.villalba.com.br
  • 2. O problema
    Leia o nome de 500 pessoas e imprima seus nomes em ordem alfabética.
  • 3. Forma Inviável
    1. algoritmo "Inviável"
    2. var
    3. nome1, nome2, nome3, nome4, nome5,..., nome499, nome500: literal
    4. inicio
    5. leia (nome1,nome2,...,nome500)
    6. ...
    7. Fimalgoritmo
  • 4. Variáveis indexadas
    A declaração de uma variável indexada corresponde, na verdade, à declaração de várias variáveis cujo identificador difere apenas por um índice.
    O índice corresponde a um valor numérico começando por 1.
    Cada variável indexada pode receber valores no decorrer do algoritmo como se fosse uma variável comum.
  • 5. Vetores
    Variáveis indexadas com uma única dimensão, também conhecidas como vetores, são referenciadas por um único índice.
    Nomes
  • 6. Forma de Representação Portugol
    <identificador> : vetor [<tamanho>] de < tipo >
    Tamanho [VI..VF]=> Vi= Valor inicial e VF valor Final
    Exemplos
    IDADE: VETOR [1..5] DE INTEIRO
    NOMES: VETOR [1..5] DE CARACTERE
    IDADE
    NOMES
  • 7. Forma de Representação Portugol
    IDADE: VETOR [1..5] DE INTEIRO
    NOMES: VETOR [1..5] DE CARACTERE
    NOMES[1], NOMES[2], NOMES[3], NOMES[4], NOMES[5]
    IDADE[1], IDADE[2], IDADE[3], IDADE[4], IDADE[5]
    IDADE
    NOMES
    IDADE[2] = 12
    IDADE[4] = 18
    NOMES[3] = José
  • 8. Atividade Exemplo
    Algoritmo que lê um vetor NUMERO de 6 posições e o escreve. A seguir, ele conta quantos valores de NUMERO são negativos e escreva esta informação.
  • 9. Resolução
    2
    conta_neg = 0
    1
    5
    2
    4
    6
    5
    4
    2
    i =
    1
    3
    6
    1
    3
    Algoritmo "vetores"
    VAR
    NUMERO: VETOR [1..6] DE REAL
    I, conta_neg: INTEIRO
    inicio
    conta_neg<- 0
    para i de 1 ate 6 faca
    leia (NUMERO[i])
    se NUMERO[i] < 0 entao
    conta_neg<- conta_neg + 1
    fimse
    fimpara
    para i de 1 ate 6 faca
    escreval(NUMERO[i])
    fimpara
    escreva ("Total de números negativos: ", conta_neg)
    fimalgoritmo
    NUMERO
    12
    1
    26
    2
    -2
    3
    -5
    4
    8
    5
    10
    NUMERO[3]
    6
    NUMERO[1]
    NUMERO[2]
    NUMERO[4]
    NUMERO[6]
    NUMERO[5]
    12
    26
    -2
    -5
    8
    10
    Total de números negativos: 2
  • 10. Exercicio Nível 1
    Escreva um algoritmo que lê um vetor A(10) e escreva a posição de cada elemento igual a 10 deste vetor.
    Escrever um algoritmo que lê um vetor X(100) e o escreve. Substitua, a seguir, todos os valores nulos de X por 1 e escreva novamente o vetor X.
    Faça um algoritmo que leia 100 valores e os escreva na ordem contrária à que foram digitados.
    Escrever um algoritmo que lê um vetor N(80) e o escreve. Encontre, a seguir, o menor elemento e a sua posição no vetor N e escreva: "O menor elemento de N é = ... e a sua posição é ... ".
  • 11. Exercicio Nível 1I
    Faça um algoritmo para calcular a média aritmética de uma quantidade 10 de valores numéricos lidos.
    Escrever um algoritmo que lê um vetor N(20) e o escreve. Troque, a seguir, o 1* elemento com o último, o 2* com o penúltimo, etc até o 10* com o 11* e escreva o vetor N assim modificado.
    Um armazém trabalha com 50 mercadorias diferentes. O dono do armazém anota a descrição, a quantidade de cada mercadoria vendida durante o mês e o seu preço unitário. Faça um algoritmo para calcular o faturamento mensal do armazém.
    Faça um algoritmo para ler um vetor de 10 elementos numéricos e verificar se existem elementos iguais a 30. Se existirem, escreva as posições em que estão armazenados.
  • 12. Exercicio Nível 1I1
    Escreva um algoritmo que gera os 10 primeiros números primos acima de 100 e os armazena em um vetor X(10) escrevendo, no final, o vetor X.
    Escrever um algoritmo que lê um vetor G(13) que é o gabarito de um teste de loteria esportiva, contendo os valores 1(coluna 1), 2(coluna 2) e 3(coluna do meio). Ler, a seguir, para cada apostador, o número de seu cartão e um vetor Resposta R(13). Verificar para cada apostador o número de acertos e escrever o número do apostador e seu número de acertos. Se tiver 13 acertos, acrescentar a mensagem: "GANHADOR, PARABENS".
    Escrever um algoritmo que lê um vetor A(15) e o escreve. Ordene a seguir os elementos de A em ordem crescente e escreva novamente A.
  • 13. Exercício Ninja
    Escrever um algoritmo que lê, para um vetor V(30), vinte valores que ocuparão as 20 primeiras posições do vetor V.
    Ordene, a seguir, os elementos de V em ordem crescente.
    Leia, a seguir 10 valores A, um por vez, e insira-os nas posições adequadas do vetor V, de forma que o mesmo continue ordenado em ordem crescente.
    Escreva o vetor V assim formado.

×