• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Aula 04  Estruturas de repetição 02 - Para Faça
 

Aula 04 Estruturas de repetição 02 - Para Faça

on

  • 5,971 views

Algoritmo 2

Algoritmo 2
MA12N

Statistics

Views

Total Views
5,971
Views on SlideShare
5,957
Embed Views
14

Actions

Likes
0
Downloads
45
Comments
0

1 Embed 14

http://www.ifms.edu.br 14

Accessibility

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Aula 04  Estruturas de repetição 02 - Para Faça Aula 04 Estruturas de repetição 02 - Para Faça Presentation Transcript

    • Algoritmo 2 – Aula 4
      MA12N
      Prof Eder SamaniegoVillalba
    • Estruturas de Repetição (Parte 02)
      Laços Contados
      Para.. faça
    • Laços Contados
      Para algumas aplicações, o controle condicional de laços imposto pela construção ”enquanto”, é desnecessariamente complicado. Em muitos casos, pode-se desejar executar um laço, um número fixo de vezes, onde este número já é conhecido. Para aplicações como estas, existe uma forma modificada de construção repetitiva.
      para variável = valor-inicial até valor-final [de <inc/dec> em <inc/dec>] faça
      comando(s)
      fim-para
    • Exemplo
      ALGORITMO “exemplo1 da estrutura para “
      Var
      TOTALREP 5
      NOME : literal
      Inicio
      I : inteiro
      para I=1 até TOTALREP faça
      escreva (“Entre com o nome: “)
      leia(NOME)
      escreva (I,” - “,NOME)
      fimpara
      fimalgoritmo
    • Exemplo 2
      Algoritmo que lê 5 números e escreve todos os que forem positivos.
      1. Algoritmo "Positivos"
      2. var
      3. i, numero: inteiro
      4. inicio
      5. para i de 1 ate 5 passo 1 faca
      6. escreval("Digete um numero")
      7. leia (numero)
      8. se numero>0 entao
      9. escreva (numero)
      10. fimse
      11. fimpara
      12. fimalgoritmo
    • Exemplo 3
      Algoritmo que lê um número N e escreve todos os números de 1 a N.
      1. algoritmo "determina o tamanho do laço"
      2. var
      3. i, N: INTEIRO
      4. inicio
      5. leia (N)
      6. para i de 1 ate N faca
      7. escreva (i)
      8. fimpara
      9. fimalgoritmo
    • Exercícios
      Escrever um algoritmo que leia informações sobre um grupo de 250 pessoas e calcule alguns dados estatísticos. Para cada pessoas do grupo deve ler o nome da pessoa, a altura, o peso e o sexo (“F” para feminino e “M” para o masculino). Calcular e escrever:
      A quantidade total de homens e mulheres e o percentual de cada.
      A média de peso das pessoas (somatório dos pesos de todas as pessoas pela quantidade de pessoas)
      O nome da pessoa mais alta.
      Faça um algoritmo que gere uma tabela com os números de 1 a 10 e mostre o seu quadrado, cubo, fatorial, número de divisores e uma mensagem dizendo se o número é primo ou não. A cada 20 linhas deve ser escrito o cabeçalho novamente:
      Número Quadrado Cubo Fatorial Divisores Primo
      1 1 1 1 1 Sim
      2 4 8 2 2 Sim