Algoritmo 2 – Aula 2<br />MA12N<br />ProfEder SamaniegoVillalba<br />
Algoritmo<br />Vamos supor que, em um dado algoritmo, um comando genérico W deve ser executado apenas quando forem satisfe...
Se então se<br />Então Se<br />Se <condição1><br /> então se <condição2><br />   então se <condição3><br />     então se <...
Algoritmo<br />Vamos supor que em determinado algoritmo uma variável X possa assumir apenas quatro valores, V1, V2, V3, V4...
Utilizando Encadeamento<br />se (X=V1) <br />   então C1<br />senao se (X=V2)<br />entao C2<br />senaose (X=V3)<br />entao...
Mútipla Escolha<br />Quando um conjunto de valores precisa ser testado e ações diferentes são associadas a esses valores, ...
escolha - caso<br />escolha<br />valor<br />opção<br />fimescolha<br />exceção<br />expressão aritmética<br />valor<br />v...
Algoritmo<br />Construa um algoritmo que, tendo como dados de entrada o nome e o código do curso de um aluno escreva seu n...
Resolução<br />Algoritmo escolha<br />Var nome: literal<br />codigo: inteiro<br />Inicio<br />escreva(“Digite seu nome”)<b...
Exercício 1<br />Faça um algoritmo Menu de Opções, que para cada uma das opções abaixo lidas, imprima as seguintes mensage...
Resolução Ex. 1<br />Algoritmo Exemplo1<br />Var OPCAO : inteiro <br />Início<br />OP11 <br />OP22 <br />OP3 3 <br />OP...
Exercício 2<br />Elabore um algoritmo que leia duas variáveis dadas pelo usuário, em seguida apresente um menu para o usuá...
Upcoming SlideShare
Loading in …5
×

Aula 02 - Escolha caso

1,224 views
1,054 views

Published on

Algoritmo 2
MA12N

Published in: Technology, Education
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
1,224
On SlideShare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
22
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Aula 02 - Escolha caso

  1. 1. Algoritmo 2 – Aula 2<br />MA12N<br />ProfEder SamaniegoVillalba<br />
  2. 2. Algoritmo<br />Vamos supor que, em um dado algoritmo, um comando genérico W deve ser executado apenas quando forem satisfeitas as condições <Condição 1>, <Condição 2>,<Condição 2> e <Condição 4><br />
  3. 3. Se então se<br />Então Se<br />Se <condição1><br /> então se <condição2><br /> então se <condição3><br /> então se <condição4><br /> então W<br />fimse<br />fimse<br />fimse<br />Utilizando E<br />Se (<condição1> e <condição2> e <condição3> e <condição4>)<br />entao W<br />fimse<br />
  4. 4. Algoritmo<br />Vamos supor que em determinado algoritmo uma variável X possa assumir apenas quatro valores, V1, V2, V3, V4, e que exista um comando diferente que será executado para cada valor armazenado em X<br />
  5. 5. Utilizando Encadeamento<br />se (X=V1) <br /> então C1<br />senao se (X=V2)<br />entao C2<br />senaose (X=V3)<br />entao C3<br />senaose (X=V4)<br />entao C4<br />fimse<br />fimse<br />fimse<br />fimse<br />Então Se<br />Se (X=V1)<br />entao C1<br />Fimse<br />Se (X=V2)<br />entaoC2<br />Fimse<br />Se (X=V3)<br />entaoC3<br />Fimse<br />Se (X=V4)<br />entaoC4<br />Fimse<br />Se então se<br />
  6. 6. Mútipla Escolha<br />Quando um conjunto de valores precisa ser testado e ações diferentes são associadas a esses valores, estamos diante de uma seleção encadeada homogêneado tipo se-senao-se.<br />
  7. 7. escolha - caso<br />escolha<br />valor<br />opção<br />fimescolha<br />exceção<br />expressão aritmética<br />valor<br />variável caracter<br />opção<br />caso<br />ação<br />constante<br />exceção<br />caso contrário<br />ação<br />escolha X .<br />caso V1:C1<br />caso V2:C2<br />caso V3:C3<br />caso V4:C4<br />fimescolha<br />
  8. 8. Algoritmo<br />Construa um algoritmo que, tendo como dados de entrada o nome e o código do curso de um aluno escreva seu nome e o curso que ele faz. De acordo com a legenda abaixo:<br />
  9. 9. Resolução<br />Algoritmo escolha<br />Var nome: literal<br />codigo: inteiro<br />Inicio<br />escreva(“Digite seu nome”)<br />leia(nome)<br />escreva(“Digite o código de curso”)<br />leia(codigo)<br />escolha codigo<br /> caso 1 : escreva (nome, “ – Informática Vespertino”)<br /> caso 2 : escreva (nome, “ – Informática Matutino”)<br /> caso 3 : escreva (nome, “ – Agricultura Vespertino”)<br /> caso 4 : escreva (nome, “ – Agricultuta Matutino”)<br /> caso 5 : escreva (nome, “ – Proeja”)<br />casocontrario : escreva(“Código Inválido”)<br />fimescolha<br />fimalgoritmo<br />
  10. 10. Exercício 1<br />Faça um algoritmo Menu de Opções, que para cada uma das opções abaixo lidas, imprima as seguintes mensagens: <br />
  11. 11. Resolução Ex. 1<br />Algoritmo Exemplo1<br />Var OPCAO : inteiro <br />Início<br />OP11 <br />OP22 <br />OP3 3 <br />OP4 4 <br />escreva (“Entre com uma opção de 1 a 4: “) <br />leia (OPCAO) <br />escolha<br /> caso OPCAO = OP1 <br /> escreva (“Executa a rotina de Inclusão de Professores”) <br /> caso OPCAO = OP2 <br /> escreva (“Executa a rotina de Alteração de Professores”) <br /> caso OPCAO = OP3 <br /> escreva (“Executa a rotina de Exclusão de Professores”) <br /> caso OPCAO = OP4 <br /> escreva (“Executa a rotina de Consulta de Professores”) <br /> caso contrário (senão) <br /> escreva (“Opção Inválida ! As opções válidas são de 1 a 4.”) <br />fimescolha<br />escreva (“A opção lida foi: ” , OPCAO) <br />Fimalgoritmo<br />
  12. 12. Exercício 2<br />Elabore um algoritmo que leia duas variáveis dadas pelo usuário, em seguida apresente um menu para o usuário perguntando qual operação matemática ele deseja executar. Cuidado com a divisão que não pode ser por 0 (zero).<br />

×