• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
EJERCICIOS DE ALGORITMOS
 

EJERCICIOS DE ALGORITMOS

on

  • 66,162 views

 

Statistics

Views

Total Views
66,162
Views on SlideShare
66,000
Embed Views
162

Actions

Likes
8
Downloads
610
Comments
7

6 Embeds 162

http://gissgur.milaulas.com 119
http://tecnicosistemaietaggrupo3.blogspot.com 21
http://tecnolonce.blogspot.com 17
http://nuevastecnologiasbj.wordpress.com 3
http://widgetsymas.webnode.es 1
http://www.tecnolonce.blogspot.com 1

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel

17 of 7 previous next Post a comment

  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
  • Hola quien me ayuda con este algoritmo no lo puedo resolver estoy comenzando en esto.
    Realizar un algoritmo que permita allá la suma de los 10 primero número enteros positivos y su promedió y presentar el resultado en pantalla.
    Are you sure you want to
    Your message goes here
    Processing…
  • gracias infinitas y bendiciones por tu ayuda
    Are you sure you want to
    Your message goes here
    Processing…
  • gracias
    Are you sure you want to
    Your message goes here
    Processing…
  • graciasss!!
    Are you sure you want to
    Your message goes here
    Processing…
  • Gracias
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    EJERCICIOS DE ALGORITMOS EJERCICIOS DE ALGORITMOS Presentation Transcript

    • Ejercicios de algoritmos
    • Hecho por:
      Liz brigitte bustos escobar
      Ivon johana Carvajal
      1002
    • 1. haga el algoritmo en pseudocodigo que, dada una variable cuyo es leido desde teclado imprima por pantalla si el numero es o no mayor que 0:
      algoritmo mayor que 0
      Variable
      entero: n
      Inicio
      Escribe: “escribe un numero”
      Leer n
      Si ( n >o) entonces
      Escribe “el numero es mayor que 0”
      Sino
      Escribe “el numero no es mayor que 0”
      FinSi
      fin
    • 2. Haga el algoritmo en pseudocodigo que dada una variable cuyo valor es leido desde teclado imprima por pantalla si el numero es o no es mayor que 0 y si el numero es par o impar:
      Algoritmo mayor que 0 par
      Variable
      Entero: n
      Inicio
      Escribe “escribe un numero”
      Leer n:
      Si ( n >o) entonces
      Escribe “el numero es mayor que 0”
      Sino
      Escribe “el numero no es mayor que 0”
      FinSi
      Si (resto de ( n/2) =0) entonces
      Escribe “y es un numero par”
      Sino
      Escribe “y es un numero impar”
      Finsi
      fin
    • 3.Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden
      decreciente.
      PROGRAMA contador2
      ENTORNO:
      c <- 100
      ALGORITMO:
      Borrar_pantalla( )
      MIENTRAS c <= 0 HACER
      ESCRIBIR c
      c <- c - 1
      FINMIENTRAS
      FIN
    • 4.Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100.
       
      PROGRAMA pares
      ENTORNO:
      c <- 2
      ALGORITMO:
      Borrar_pantalla( )
      MIENTRAS c < 101 HACER
      ESCRIBIR c
      c <- c + 2
      FINMIENTRAS
      FIN
    • 5.Desarrolle un algoritmo que permita calcular Promedio de Notas; finaliza cuando N = 0.
      1. Inicio
      2. Declaración de Variables:
      N = 0, Promedio = 0, Acumula= 0
      3. Leer N
      4. Mientras N <> 0 hacer
      5. Cuenta = Cuenta + 1
      6. Acumula = Acumula + N
      7. Fin Mientras
      8. Promedio = Acumula/Cuenta
      9. Imprimir “Promedio:”; Promedio
      10. Fin
    •  
      6.Introducir una frase por teclado. Imprimirla en el centro de la pantalla.
       
      PROGRAMA centro
      ENTORNO:
      res <- "S"
      frase <- Espacios( 40 )
      ALGORITMO:
      MIENTRAS res = "S" HACER
      Borrar_pantalla( )
      EN 5,15 ESCRIBIR "Frase: "
      EN 5,22 LEER frase
      EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase
      HACER Mas
      FINMIENTRAS
      FIN
       
    • 7.Introducir tantas frases como queramos y contarlas.
       
      PROGRAMA frases
      ENTORNO:
      res <- "S"
      frase <- Espacios( 30 )
      c <- 0
      ALGORITMO:
      Borrar_pantalla( )
      MIENTRAS res = "S" HACER
      ESCRIBIR "Frase: "
      LEER frase
      c <- c + 1
      ESCRIBIR "Deseas introducir m s frases (S/N): "
      LEER res
      FINMIENTRAS
      ESCRIBIR "El n£mero de frases introducidas son: "
      ESCRIBIR c
      FIN
       
    • 8.Introducir un numero por teclado. Que nos diga si es par o impar.
       
      PROGRAMA paridad
      ENTORNO:
      num <- 0
      ALGORITMO:
      Borrar_pantalla( )
      ESCRIBIR "Introduce un n£mero: "
      LEER num
      SI num = int( num / 2 ) * 2 ENTONCES
      ESCRIBIR "es par"
      SINO
      ESCRIBIR "es impar"
      FINSI
      FIN
       
    • 9.mprimir y contar los multiplos de 3 desde la unidad hasta un numero que
      introducimos por teclado.
      PROGRAMA multiplo3
      ENTORNO:
      i <- 3
      n <- 0
      c <- 0
      ALGORITMO:
      Borrar_pantalla( )
      ESCRIBIR "N£mero: "
      LEER n
      MIENTRAS i <= n HACER
      SI i = int( i / 3 ) * 3 ENTONCES
      ESCRIBIR i
      c <- c + 1
      FINSI
      i <- i + 1
      FINMIENTRAS
      ESCRIBIR "El n£mero de m£ltiplos de 3 son: "
      ESCRIBIR c
      FIN
       
    •  
      10.Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre1 y 100.
      PROGRAMA multiplo_2_3
      ENTORNO:
      i <- 1
      c <- 0
      ALGORITMO:
      Borrar_pantalla( )
      MIENTRAS i < 101 HACER
      SI i = int( i / 2 ) * 2 O i = int( i / 3 ) * 3 ENTONCES
      c <- c + 1
      ESCRIBIR i
      FINSI
      i <- i + 1
      FINMIENTRAS
      ESCRIBIR "El n£mero de m£ltiplos es de: "
      ESCRIBIR c
      FIN
       
    • 11.Determinar cual de 2 números es mayor:
      1. algoritmo mayor
      2. var
      3. a,b: entero;
      4. inicio
      5.Escriba(“Por Favor entre un número”);
      6.Lea(a);
      7.Escriba(“por favor entre el segundo número”);
      8.lea (b);
      9.si (a>b)
      10.escriba(“El mayor de los números es: ”,a);
      11. sin_no
      12.escriba(“El mayor de los números es: ”,b);
      13. fin_si
      14. fin
    • 12.Realizar un algoritmo que sume los 10 primeros números naturales e imprima
      su resultado.
      Solución
      1. algoritmo suma10
      2. var
      3. k,suma : entero;
      4. inicio
      5. suma=0;
      6. Para (k=1 hasta 10 hacer)
      7.suma=suma+k;
      8. fin_para
      9. Escriba(“la suma es: ”,suma);
      10. fin
    • 13.Una pequeña variación al ejercicio anterior Realizar la suma de 10 números cualesquiera e imprimir su resultado
      algoritmo suma10_1
      var
      k, numero, suma : entero;
      inicio
      suma=0;
      Para (k=1 hasta 10 hacer)
      Escriba(“por Favor Ingrese número”);
      lea(numero)
      suma=suma+numero;
      fin_para
      Escriba(“la suma es: ”,suma);
      fin
    • 14.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar.
      1. Inicio
      2. Declaración de variables: N
      3. Leer un número
      4. Asignarlo a la variable N
      5. Si el residuo de dividir a N entre 2 es
      igual a cero
      6. Si es Si: Entonces: Escribir “ Es par”
      7. Sino: Escribir “Es impar”
      8. Fin_Si
      9. Fin
    • 15.Retomado el primer ejercicio de los diagramas, Leer dos números, sumarlos y
      obtener su resultado
      1. Algoritmo Suma;
      2. Var
      3. a,b,suma: entero;
      4. inicio
      5. escriba(“por favor ingrese un número”);
      6. lea (a);
      7. escriba(“por favor ingrese otro número”);
      8. lea (b);
      9. suma = a+b;
      10. escriba (“el resultado es: ”,suma)
      11. fin
    • 16.Introducir una frase por teclado. Imprimirla cinco veces en filas
      consecutivas, pero cada impresion ir  desplazada cuatro columnas hacia laderecha.
       
      PROGRAMA frase
      ENTORNO:
      frase <- Espacios( 30 )
      ALGORITMO:
      Borrar_pantalla( )
      EN 5,15 ESCRIBIR "Frase: "
      EN 5,22 LEER frase
      fi <- 8
      co <- 15
      veces <- 0
      MIENTRAS veces <= 5 HACER
      EN fi,co ESCRIBIR frase
      veces <- veces + 1
      co <- co + 4
      fi <- fi + 1
      FINMIENTRAS
      FIN
    • 17.Introducir una frase por teclado. Imprimirla en el centro de la pantalla.
       
      PROGRAMA centro
      ENTORNO:
      res <- "S"
      frase <- Espacios( 40 )
      ALGORITMO:
      MIENTRAS res = "S" HACER
      Borrar_pantalla( )
      EN 5,15 ESCRIBIR "Frase: "
      EN 5,22 LEER frase
      EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase
      HACER Mas
      FINMIENTRAS
      FIN
    • 18.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso.
      1. Inicio
      2. Declaración de Variables:
      A = 0, B = 0, Temporal = 0
      3. Leer A y B
      4. Si A<B Entonces
      5. Asignar a Temporal = B
      6. Asignar a B = A
      7. Asignar a A = Temporal
      8. Si no (De lo contrario)
      9. Fin_Si
      10 Escribir “Orden = “, A, B
      11. Fin
    • 19.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).
      1. Inicio
      2. Declaración de variables: R = 0, H = 0
      3. Leer el valor de Radio (R) y Altura (H)
      4. Calcular el Volumen aplicando la fórmula
      5. Calcular el valor del área aplicando la
      fórmula respectiva
      6. Escribir el valor del Área y del Volumen
      7. Fin
    • 20.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil, expresada en kilómetros por hora, proporcione la velocidad en metros por segundo.
      1. Inicio
      2. Declaración de Variables:
      Vel = 0
      3. Leer Datos: Vel
      4. Versal = (Vel * 1000) / 3600
      5. Imprimir resultado
      6. Fin
    • 21.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente.
      1. Inicio
      2. Declaración de Variables: CatA= 0, CatB=0
      3. Leer el valor de cada cateto
      4. Almacenarlo en la variable CatAy CatB
      5. Calcular el valor de Hip con la formula indicada
      6. Escribir el valor de la Hipotenusa
      7. Fin
    • 22.Desarrolle un algoritmo que permita leer dos valores distintos, determinar cual de los dos valores es el
      mayor y escribirlo.
      1. Inicio
      2. Inicializar variables: A = 0, B = 0
      3. Solicitar la introducción de dos valores distintos
      4. Leer los dos valores
      5. Asignarlos a las variables A y B
      6. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos
      7. Si A>B Entonces Escribir A, “Es el mayor”
      8. De lo contrario: Escribir B, “Es el mayor”
      9. Fin_Si
      fin
    • 23.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.
      1. inicio
      2. Inicializar las variables A, B y C
      3. Leer los tres valores
      4. Almacenar en las variables A, B y C
      5. Si A > B y A > C Entonces
      6. Escribir A “Es el mayor”
      7. Sino
      8. Si B > A y B > C Entonces
      9. Escribir B “Es el mayor”
      10. Sino
      11. Escribir C “Es el mayor”
      12. Fin_Si
      13. Fin_Si
      14. Fin
    • 24.Hacer un programa que imprima la suma de los 100 primeros numeros.
       
      PROGRAMA suma
      ENTORNO:
      c <- 1
      suma <- 0
      ALGORITMO:
      Borrar_pantalla( )
      MIENTRAS c <= 100 HACER
      suma <- suma + c
      c <- c + 1
      FINMIENTRAS
      ESCRIBIR "La suma de los 100 primeros n£meros es: "
      ESCRIBIR suma
      FIN
       
    • 25.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 + 3 + …. + 10.
      1. Inicio
      2. Declaración de variables:
      N= 0, Suma = 0
      3. Asignación Contador :
      N = N + 1
      4. Asignación Acumulador:
      Suma = Suma + N
      5. Si N = 10 Entonces
      6. Escribir Suma
      7. De lo contrario, Repetir desde el
      paso 3
      8. Fin_Si
      9. fin