Trabajo de Algoritmo<br />Bernate Sáenz Juan David<br />Salgar buitrago Daniela<br />1002<br />2011<br />
Comprobar si un numero entero positivo ingresado desde el teclado es par Algoritmo NPAR<br />   var:nro:entero <br />   co...
Una agencia de venta de autos paga a su personal de ventas un salario de $800,00 mas una comisión de $170,00 por auto vend...
En un curso de ciencias de la computación la calificación final del estudiante se determina a partir del rendimiento en tr...
Indicar cual es el valor de la variables RESULTADO, después de la ejecución de las siguientes acciones (suponer que son re...
Indicar el resultado y el tipo, de cada una de las siguientes expresiones.<br />a)5^3+4 = 129 entero b)2.0^3+5 = 13.0 real...
Escribir las siguientes expresiones aritméticas, en un lenguaje de programación, cuyos operadores aritméticos, son:<br />+...
Leer un libro Algoritmo LIBRO<br />comienzo 1.tomar libro 2.abrir tapa 3.repetir leer hoja hasta que (no mas texto) 4.repe...
Cambiar la rueda de un automóvil<br />Algoritmo AUTOMOVIL comienzo 1.situar gato en el lugar adecuado 2.repetir accionar g...
De un mazo de cartas españolas se desean formar cuatro pilas, una para cada palo, teniendo en cuenta que solo se puede mir...
De una sola tirada de 5 dados, informar si se ha formado generala, tomando de a un dado por vez y comparando de a dos. <br...
Buscar el rey de copas en un mazo de naipes. Sólo puede mirar una carta por vez.<br />Algoritmo CARTAS comienzo 1.tomar ma...
Calcular el promedio de tres números Algoritmo PROMEDIO var: N1,N2,N3,PROM: REAL<br />comienzo1.leer N1,N2,N3 2.P N1+N2+N3...
Diseñar un algoritmo para cambiar una lamparita quemada de un artefacto suspendido en el techo. Utilizar la técnica de ref...
Desarrolle un algoritmo que permita leer dos valores distintos, determinar cual de los dos valores es el mayor y escribirl...
Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algorit...
Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 +...
Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo c...
Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).<br />1. In...
Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar<br />1. Inicio <br...
Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso<br />1. Inicio <br />2. ...
Desarrolle un algoritmo que  permita leer un valor entero positivo N y determinar si es primo o no. <br />1. Inicio <br />...
Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil, expresada en kilómetros por hora, propor...
Desarrolle un algoritmo que permita calcular Promedio de Notas; finaliza cuando N = 0. <br />1. Inicio <br />2.  Declaraci...
Desarrolle un algoritmo para la empresa Constructora Tecnovivir Casas C.A., que le permita calcular e imprimir la nómina p...
Desarrolle un algoritmo que funcione como caja registradora, <br />1. Inicio <br />2. Declaración de Variables: <br />Sub_...
10. Fin_Mientras<br />11.  IVA = Subtotal * 0,15 <br />12. Total = Subtotal + IVA <br />13.  Imprimir “Sub Total : “, Subt...
Upcoming SlideShare
Loading in...5
×

Trabajo de algoritmo

2,254

Published on

Published in: Education
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total Views
2,254
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
31
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Trabajo de algoritmo

  1. 1. Trabajo de Algoritmo<br />Bernate Sáenz Juan David<br />Salgar buitrago Daniela<br />1002<br />2011<br />
  2. 2. Comprobar si un numero entero positivo ingresado desde el teclado es par Algoritmo NPAR<br /> var:nro:entero <br /> comienzo leer NRO si ((-1)^NRO>0) entonces escribir PAR sino escribir NO ES PAR fin_si fin<br />
  3. 3. Una agencia de venta de autos paga a su personal de ventas un salario de $800,00 mas una comisión de $170,00 por auto vendido mas un 5% del valor de venta. Diseñar un algoritmo para calcular el salario de un vendedor en un determinado mes, conociendo el nº de automóviles vendidos y el total del monto de ventas.<br /> Algoritmo ST var: S, NA, PT: reales comienzo leer NA,PT ST SM+ 100*NA+PT*0.05 escribir S fin<br />
  4. 4. En un curso de ciencias de la computación la calificación final del estudiante se determina a partir del rendimiento en tres aspectos del trabajo. Existe una calificación de exámenes parciales, que cuenta con 30% del total, la calificación de trabajo de taller con 20%, y el examen final con el 50%. Diseñar un algoritmo para calcular la calificación final del estudiante<br />Algoritmo CALIFICACION var:EP,TT,EF:realcomienzo leer EP,TT,EF C EP*0.3+PI*0.2+EF*0.5 escribir C fin<br />
  5. 5. Indicar cual es el valor de la variables RESULTADO, después de la ejecución de las siguientes acciones (suponer que son reales)<br />a)x 3.0 b)y 5.0 c)RESULTADO x*y+xd)RESULTADO 6 x 4 RESULTADO RESULTADO *x^2 RESULTADO 96.0<br />
  6. 6. Indicar el resultado y el tipo, de cada una de las siguientes expresiones.<br />a)5^3+4 = 129 entero b)2.0^3+5 = 13.0 real c)1/3+1/2 = 5/6 entero d)1/4+4 = 17/4 entero e)2*3/6 = 1 entero f)2+6*3.0+4^2 = 36.0 real<br />
  7. 7. Escribir las siguientes expresiones aritméticas, en un lenguaje de programación, cuyos operadores aritméticos, son:<br />+,-,*,/ y ^ a) x+yb)(a+b)/(c+d) c)(a+(b/(c+d)))/((1-x)/y) d)(a/b-1)/(d/c-1) e)x^5 f)(x+y)^3<br />
  8. 8. Leer un libro Algoritmo LIBRO<br />comienzo 1.tomar libro 2.abrir tapa 3.repetir leer hoja hasta que (no mas texto) 4.repetir cambiar hoja hasta que (no mas hojas) fin<br />
  9. 9. Cambiar la rueda de un automóvil<br />Algoritmo AUTOMOVIL comienzo 1.situar gato en el lugar adecuado 2.repetir accionar gato hasta que (auto alcanza altura adecuada) 3.repetir colocar herramienta sobre tuerca 3.2 repetir girar herramienta en sentido anti horario hasta que (tuerca floja) hasta que (todas las tuercas sueltas 4.sacar rueda 5.colocar rueda nueva 6.repetir colocar herramienta sobre tuerca 6.1 repetir girar herramienta sentido horario hasta que (tuerca ajustada) hasta que (todas las tuercas ajustadas) 7.repetir accionar gato Hasta que (auto llegue al piso) fin<br />
  10. 10. De un mazo de cartas españolas se desean formar cuatro pilas, una para cada palo, teniendo en cuenta que solo se puede mirar de una carta por vez.<br />Algoritmo CARTAS var: CARTA, P1, P2, P3, P4: entero P(PILA) comienzo leer CARTA repetir si CARTA=E entonces carta en P1 si CARTA=B entonces carta en P2 si CARTA=C entonces carta en P3 sino carta en p4 finsihasta que (¿No mas cartas?) fin<br />
  11. 11. De una sola tirada de 5 dados, informar si se ha formado generala, tomando de a un dado por vez y comparando de a dos. <br />Algoritmo GENERALA var: A B C D E :entero comienzo leer A B si (a=b) entonces leer c si (c=b) entonces leer d si (d=c) entonces leer e si (e=d) entonces escribir GENERALA sino escribir NO GENERALA finsifin<br />
  12. 12. Buscar el rey de copas en un mazo de naipes. Sólo puede mirar una carta por vez.<br />Algoritmo CARTAS comienzo 1.tomar mazo de cartas 2. repetir cambiar carta hasta que encontrar rey de copas fin<br />
  13. 13. Calcular el promedio de tres números Algoritmo PROMEDIO var: N1,N2,N3,PROM: REAL<br />comienzo1.leer N1,N2,N3 2.P N1+N2+N3/3 3.escribir P fin<br />
  14. 14. Diseñar un algoritmo para cambiar una lamparita quemada de un artefacto suspendido en el techo. Utilizar la técnica de refinamientos sucesivos. <br />Algoritmo LAMPARITA comienzo 1. situar escalera debajo del artefacto que tiene la lamparita quemada 2. repetir subir un peldaño hasta que (¿la mano alcanza la lamparita?) (¿hay más peldaño?) 3. repetir girar lamparita sentido anti horario hasta que (¿lamparita suelta?) 4. sacar lamparita 5. repetir bajar peldaño hasta que (¿llegar al piso?) 6. repetir subir un peldaño hasta que (¿la mano alcanza la lamparita?) (¿hay mas peldaños?) 7. poner la lamparita 8. repetir girar lamparita sentido horario hasta que (¿lamparita ajustada?) 9. repetir bajar peldaño hasta que (¿llegar al suelo?) fin<br />
  15. 15. Desarrolle un algoritmo que permita leer dos valores distintos, determinar cual de los dos valores es el mayor y escribirlo.<br />1. Inicio <br />2. Inicializar variables: A = 0, B = 0 <br />3. Solicitar la introducción de dos <br />valores distintos <br />4. Leer los dos valores <br />5. Asignarlos a las variables A y B <br />6. Si A = B Entonces vuelve a 3 <br />porque los valores deben ser <br />distintos <br />7. Si A>B Entonces <br />8. De lo contrario: Escribir B, “Es <br />el mayor” <br />9. Fin_Si<br />10. Fin scribir A, “Es el mayor”<br />
  16. 16. Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.<br />1. Inicio <br />2. Inicializar las variables A, B y C <br />3. Leer los tres valores <br />4. Almacenar en las variables A, B <br />y C <br />5. Si A > B y A > C Entonces <br />6. Escribir A “Es el mayor” <br />7. Sino <br />8. Si B > A y B > C Entonces <br />9. Escribir B “Es el mayor” <br />10. Sino <br />11. Escribir C “Es el mayor” <br />12. Fin_Si<br />13. Fin_Si<br />14. Fin<br />
  17. 17. Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 + 3 + …. + 10.<br />1. Inicio <br />2. Declaración de variables: <br /> N= 0, Suma = 0 <br />3. Asignación Contador : <br />N = N + 1 <br />4. Asignación Acumulador: <br />Suma = Suma + N <br />5. Si N = 10 Entonces <br />6. Escribir Suma <br />7. De lo contrario, Repetir desde el <br /> paso 3 <br />8. Fin_Si<br />8. Fin<br />
  18. 18. Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente.<br />1. Inicio <br />2. Declaración de Variables: CatA= 0, <br />CatB=0 <br />3. Leer el valor de cada cateto <br />4. Almacenarlo en la variable CatA y <br />CatB<br />5. Calcular el valor de Hip con la <br />formula indicada <br />6. Escribir el valor de la Hipotenusa <br />7. Fin<br />
  19. 19. Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).<br />1. Inicio <br />2. Declaración de variables: R = 0, H = 0 <br />3. Leer el valor de Radio (R) y Altura (H) <br />4. Calcular el Volumen aplicando la fórmula <br />5. Calcular el valor del área aplicando la<br />fórmula respectiva <br />6. Escribir el valor del Área y del Volumen <br />7. Fin<br />
  20. 20. Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar<br />1. Inicio <br />2. Declaración de variables: N <br />3. Leer un número <br />4. Asignarlo a la variable N <br />5. Si el residuo de dividir a N entre 2 es <br />igual a cero <br />6. Si es Si: Entonces: Escribir “ Es par” <br />7. Sino: Escribir “Es impar” <br />8. Fin_Si<br />9. Fin<br />
  21. 21. Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso<br />1. Inicio <br />2. Declaración de Variables<br /> A = 0, B = 0, Temporal =<br />3. Leer A y B <br />4. Si A<B Entonces <br />5. Asignar a Temporal = <br />6. Asignar a B = A <br />7. Asignar a A = Tempor<br />8. Si no (De lo contrario) <br />9. Fin_Si<br />10 Escribir “Orden = “, A, B <br />11. Fin <br />
  22. 22. Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. <br />1. Inicio <br />2. Declaración de variables: <br /> J = 2, S =0 <br />3. Leer N <br />4. Mientras J<= N / 2 hacer <br />5. Si N / J =0 <br />6. S=S+1 <br />7. J=J+1 <br /> 8. Fin_Si<br />9. Fin del ciclo mientras <br />10. Si S = 0 Entonces <br />11. Escribir N “es primo” <br />12. Sino (De lo contrario) <br />13. Escribir N “no es primo” <br />14. Fin_Si<br />15. Fin<br />
  23. 23. Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil, expresada en kilómetros por hora, proporcione la velocidad en metros por segundo.<br />1. Inicio <br />2. Declaración de Variables: <br />Vel = 0 <br />3. Leer Datos: Vel<br />4. Versal = (Vel * 1000) / 3600 <br />5. Imprimir resultado <br />6. Fin <br />
  24. 24. Desarrolle un algoritmo que permita calcular Promedio de Notas; finaliza cuando N = 0. <br />1. Inicio <br />2. Declaración de Variables: <br />N = 0, Promedio = 0, Acumula= 0 <br />3. Leer N <br />4. Mientras N <> 0 hacer <br />5. Cuenta = Cuenta + 1 <br />6. Acumula = Acumula + N <br />7. Fin Mientras <br />8. Promedio = Acumula/Cuenta <br />9. Imprimir “Promedio:”; Promedio <br />10. Fin <br />
  25. 25. Desarrolle un algoritmo para la empresa Constructora Tecnovivir Casas C.A., que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. La hora trabajada se pautó en 30.000 Bolívares. <br />1. Inicio <br />2. Declaración de Variables: <br />Numero_Obreros =50 <br />Numero_Hora_Trabajadas = 0 <br />Total_nomina = 0 <br />3. Imprimir líneas de títulos de la nómina <br />4. Leer Datos <br />5. Mientras Numero_Obreros>0 <br />6. Salario = Numero_Hora_Trabajada * 30 <br />7. Total_nómina= Totalnómina + Salario <br />8. Numero_Obreros = Numero_Obreros - 1 <br />9. Imprimir Registro <br />10. Leer Datos <br />11. Fin_Mientras<br />12. Imprimir “Total : “, Total_nómina<br />13. Fin<br />
  26. 26. Desarrolle un algoritmo que funcione como caja registradora, <br />1. Inicio <br />2. Declaración de Variables: <br />Sub_total=0,Total = 0 <br />3. Ingrese “Código de Producto y <br />Precio:” <br />4. Almacenar Codigo_Producto, Precio <br />5. Imprimir líneas de títulos del recibo <br />de pago <br />6. Mientras Código_Producto <> “ “ <br />7. Subtotal = Subtotal + Precio <br />8. Imprimir Codigo_Producto, Precio <br />9. Ingrese “Código de Producto y <br />Precio:” <br />
  27. 27. 10. Fin_Mientras<br />11. IVA = Subtotal * 0,15 <br />12. Total = Subtotal + IVA <br />13. Imprimir “Sub Total : “, Subtotal <br />14. Imprimir “ IVA : “, IVA <br />15. Imprimir “Total: “, Total <br />16. Fin <br />
  1. ¿Le ha llamado la atención una diapositiva en particular?

    Recortar diapositivas es una manera útil de recopilar información importante para consultarla más tarde.

×